Jump to content

noted V5 Stuttering FIX


Recommended Posts

OK - I know some of us are really struggling with the mother of all stuttering on V5 - THERE IS A POSSIBLE FIX and it's on the Prepar3d forum. It's not necessarily the True Earth demands.. there's a "glitch" in the new software - it's not cpu or gpu related... which is why I'm mentioning it on the Orbx forums.

 

You should try right clicking on the Prepar3d icon, go into properties and tick the "disable fullscreen optimisations" box. Set the gpu to 30fps, unlimited in the application and restart everything. 

 

Made a huge difference for me after days of 1fps cool cpu, cool gpu hell around dense Orbx scenery areas.

 

 

 

Edited by makapala
  • Like 3
  • Thanks 1
Link to comment
Share on other sites

  • 9 months later...

A Google search took me to this thread. 

 

I just bought true earth Northern California for P3D v5.1 and I must say it looks great, however I was getting really bad stuttering in the last 1-200 feet coming in to land at KSFO, as well as noticably less smooth performance than usual.

 

I disabled full screen optimisation as described above and I now have smoother performance and no stuttering coming in to land.

 

Thanks

Link to comment
Share on other sites

3 hours ago, Calum WE said:

A Google search took me to this thread. 

 

I just bought true earth Northern California for P3D v5.1 and I must say it looks great, however I was getting really bad stuttering in the last 1-200 feet coming in to land at KSFO, as well as noticably less smooth performance than usual.

 

I disabled full screen optimisation as described above and I now have smoother performance and no stuttering coming in to land.

 

Thanks

My stuttering came back. The new true earth scenery has resulted in my HDD drive only having 27 GB remaining free of 1000 GB so maybe that's the reason. 

 

I have a new HDD ordered that I will move my Orbx library to. Hopefully that fixes it.

 

Thanks

Link to comment
Share on other sites

I had severe stuttering with the true earth northern CA /Flightbeam KSFO bundle so bad I uninstalled it. I will give this a try tomorrow. I’m glad to hear this at least worked for someone. The scenery is so beautiful.

Link to comment
Share on other sites

After I had installed the True earth Northern California, I wanted to try and up my graphics settings to make the most of the scenery.

 

I pressed the keyboard buttons to bring up the framerate numbers at the top of my screen. It always stayed near enough to 30 but I had bad stutters as I was coming in to land. After more googling I found some other forum threads saying that text at the top of your screen can cause stuttering in the latest version of P3D. 

 

I havn't brought up any text since, and so far no more stutters.

Edited by Calum WE
typos
  • Thanks 1
Link to comment
Share on other sites

6 hours ago, Calum WE said:

After I had installed the True earth Northern California, I wanted to try and up my graphics settings to make the most of the scenery.

 

I pressed the keyboard buttons to bring up the framerate numbers at the top of my screen. It always stayed near enough to 30 but I had bad stutters as I was coming in to land. After more googling I found some other forum threads saying that text at the top of your screen can cause stuttering in the latest version of P3D. 

 

I havn't brought up any text since, and so far no more stutters.

I never look at framerate counters anymore. I have a 144Hz 49" curved super ultra-wide monitor and I judge all performance based off overall smoothness. 

Link to comment
Share on other sites

After multiple flights I can concur with confidence this mostly resolves the stuttering fix. You will notice as you approach denser scenery a slight momentary stutter as scenery loads, however I believe this is normal. 

  • Thanks 1
Link to comment
Share on other sites

  • 2 months later...
On 6/17/2020 at 4:21 AM, makapala said:

You should try right clicking on the Prepar3d icon, go into properties and tick the "disable fullscreen optimisations" box. Set the gpu to 30fps, unlimited in the application and restart everything. .

 

Going to give this a try, quick question, how do I set the GPU to 30fps AND unlimited at the same time?

 

Is there another setting or app I am missing?

 

thanks

Link to comment
Share on other sites

  • 3 months later...

I can confirm that this fix is not necessary with version 5.2.  I tried with the without fullscreen optimization fix and without.  Simply capping via Nvidia control pannel and leave the settings as is works very well.  When the without fullscreen optimization option is enabled, it causes a lot of micro stutters.  I tested these options at KLAX with NA SOCAL and full AI at 7am - just to give you an idea...

Link to comment
Share on other sites

On 9/24/2021 at 6:10 PM, panzer2181 said:

I can confirm that this fix is not necessary with version 5.2.  I tried with the without fullscreen optimization fix and without.  Simply capping via Nvidia control pannel and leave the settings as is works very well.  When the without fullscreen optimization option is enabled, it causes a lot of micro stutters.  I tested these options at KLAX with NA SOCAL and full AI at 7am - just to give you an idea...

I wonder if this is the problem I’m having with the NGXu… I had it on in 5.1 and then 5.2 I started getting the mad stutters in just the NGXu.  I also need to find the NA SoCal compatibility cause I have all addon airports and there’s some extra taxiway signs floating around 

Edited by FBWFTW
Link to comment
Share on other sites

On 9/26/2021 at 4:56 PM, FBWFTW said:

I wonder if this is the problem I’m having with the NGXu… I had it on in 5.1 and then 5.2 I started getting the mad stutters in just the NGXu.  I also need to find the NA SoCal compatibility cause I have all addon airports and there’s some extra taxiway signs floating around 

Just took the NGXu for a spin at Orbx KBUR w/ true earth socal. Stutter city. I mean BAD.

  • Like 1
Link to comment
Share on other sites

On 9/29/2021 at 2:55 AM, davidzill said:

Just took the NGXu for a spin at Orbx KBUR w/ true earth socal. Stutter city. I mean BAD.

I don’t have TE SoCal-only the NA region-cause it covers Vegas as well. It’s not too bad for me but the NGXu has been stuttering wherever I go-KDEN, KBWI-just doesn’t matter.  It happened all of a sudden as well.  I just wish they’d release KPBI to sit on top of my TE Florida where I get very decent performance. 

Edited by FBWFTW
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...