Jump to content

communication error and unable to sync simulator


Recommended Posts



Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  WIN 7 64bit

Simulator:  Xplane11


Issue: Cant get everything work. Orbx Central is unable to sync with the Sim after installation and afterwards while trying to download the libraries or my newly purchased Washington HD there's always a communication error. Tried to reinstall several times, tried different library locations and complete reinstall including deleting the temp files so the installer has to ask all the stuff from the beginning. No help! actually i want my money back, since the whole process is much to complicated to me. either just generate a downloadable file that works or make sure the software works. i'm really disappointed guys. honestly... your stuff looks beautiful, but now i cant use because of this trouble...  



Link to comment
Share on other sites

Hi Fabb,


Can you please check that you have the System Requirements installed as per our User Guide? After installing the below files, restart your computer and let me know if the issue is resolved.


System Requirements


Windows 7 and onwards are supported. The following components need to be installed for Central to function correctly:



Additional Requirements for Windows 7 and 8

Link to comment
Share on other sites

Hi Ben,

greetz to VIC... Jepp, checked everthing - it's installed - no change at all! When I try to establish the Library, the program keeps thinking and thinking - then an error message appears.

"no rsponse. message timed out." and windowed the no syncronisation error.

Link to comment
Share on other sites

7 hours ago, Doug Sawatzky said:

Just an FYI


If you go to settings/My Account, you can opt into Fastlane and the newest version 4.0.25 will be available.

Updated to v4.0.25 and still error messages when trying to update scenery.

This is serious guys...how can I trust using the new Orbx central for not only new purchases but re installing should I need to?  I have $1770 worth of your scenery. I have tried everything from Anti virus/Firewall/uninstall/reinstall/redist files/old version of FTX central.

Orbx 4.025 error message.JPG

Link to comment
Share on other sites

Guest Josh Koz

Hi @Fabb,


The issue your encountering and corresponding error code in your log file normally only occurs when a PC is missing a system requirement. It's quite unusual that you're still encountering this error. Some things to try:


- Attempt to launch the following executable at let us know the error message received.


- Ensure your operating system is up to date with patches and service packs.

- Try uninstalling a reinstalling the system requirements and restarting your PC. It's possible that requirement is marked as installed in the registry even if it's not completely installed.

Link to comment
Share on other sites

  • Guest unpinned this topic


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...