Jump to content

EGLC London City Airport FAILS to Load?

Recommended Posts

This is the second Orbx purchase. First one, London City Scenery loaded fine, and looks fantastic.  However, I do take-off and land regularly at London City Airport, so decided to purchase Orbx EGLC London City Airport.  IT FAILS TO LOAD?  Goes up to 250mb then stops? I have tried several times, but keeps failing? Other downloads work fine.  I do not really want a refund, I want the Airport. PLEASE Orbx!

Link to comment
Share on other sites

53 minutes ago, Nick Cooper said:


did you buy this from Orbx Direct or from the Marketplace?

I purchased it via the FS2020 Marketplace, as I did the London City Scenery.  I have made more attempts after 4 hours from previous attempts, it still FAILS to download? I have loads of free space on my SSD's, about 750GB of free space.  The 2 Orbx downloads are the ONLY 2 paid downloads with FS2020, all the others were the free stuff downloads. No problems with my SKY Fibre internet.  How many more tries? Something wrong here?  

Link to comment
Share on other sites

I bought it over Orbx and both load in fine.


On second read though it seems you mean download when you say "load"?


That would be a known bug and there is not much that you can do. This affects all downloads in the MS content manager.


I have this problem every world update as well. Then it requires to manually download packages from the download manager and it fails all the time for the first weeks.

Then suddenly they can be downloaded.


Other ppl had luck with simply retrying it over and over but others, like me, tried it dozens of times without luck.


And I'm talking about original asobo Files. It's the same with everything there...


Few things you can try:


- Delete all cache

- restart router

- make sure you didn't limit your bandwidth, seems that can cause issues.


There are many posts about this problem in the MSFS forum.



I willl never buy an addon over the MS store, that much is sure.


Edited by Senchay
Link to comment
Share on other sites

  • 1 month later...

Its a known problem that Asobo are working on to rectify and it is a different problem to what has been discussed in this post.

A new post by yourself would have been better but if your read thru other posts in the Microsoft Simulator Support Forum you will see others are having the same problem

and also a temporary solution by Jon Clarke offered until an update is released. Have a look at the link below.


  • Thanks 1
Link to comment
Share on other sites

  • 5 months later...



I have purchased the EGLC add on for fs2020 and currently really unhappy with the product. I expected much better quality from Orbx to behonest.
I am unable to remove the static aircraft and not one stand has an option to connect ground equipment to the aircraft, such a shame.. 

If you have any suggestions on fixing this, Im all ears..

Link to comment
Share on other sites

The statics are a long standing issue, there's currently no way to remove them as it stands, or have an option in a control panel. As for the ground equipment, I'm guessing your trying to summon them through the ATC menu, I've heard the issue is to do how the parking spots are labelled in the AFCAD, anyway, I recommend using a freeware program such as pushback tool, this should fix the issue, and is what I use (until GSX arrives)

Edited by EasternT3
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...