Jump to content

Recommended Posts

Hello guys,


I don't know if I am the only one experiencing this issue. I have stutters when using London Landmarks to the point that it becomes unflyable. I have no issues with TE GB South on X-Plane, it runs butter smooth. But the topic here is MSFS. I am sending the video attached so you can see  what I am experiencing. This is MSFS vanilla, with Orbx EGLC and London Landmarks, the CJ4 is used without any mods (don't mind the flying, it is just for demonstration purposes). The video is unlisted on youtube, as it is only for debugging pursposes, and not to expose the product. 



Time line: (The resolution used is 3440x1440p)

0:00 - London landmarks ON + EGLC ON (Medium settings), endless stutters, even when not looking at the city, impossible to land, even on Medium settings, which I find very poor.
1:42 - London landmarks OFF + EGLC ON (Ultra settings) - No stutters, smooth, I don't run the sim on ultra, this is just for demonstration purposes.
5:30 - New York, Photogrammetry ON (High-end settings) - New York was put there just for good measure, to show that the issue has something to do with Orbx objects on London Landmarks, not with the amount of details and textures.




MB: Gigabyte Aoruz Z390 Pro
CPU: Core i7 9700K @4.8 GHz
RAM: 32 GB Corsair Vengeance LPX @3200 MHz 
GPU: EVGA RTX 2080 Super XC Ultra
PSU: Corsair TM650 80+ Bronze 
Storage: Samsung 970 evo (Windows partition) + Samsung Evo 850 500 GB + Seagate Barracuda 2TB  + Sabrent M.2 1 TB (FS installed here)
Cooler: Corsair H100i V2 + 4 intakes and 3 exhaust
Case: Phanteks P400 
Joystick: Thrustmaster HOTAS Warthog + TFRP Rudder 



Link to comment
Share on other sites

I don't know the technical reason why you are having this issue but it looks like the GPU is trying to catch up the scenery loading.

I am suggesting that due to the area being extremely dense and resource hungry that you may want to try lowering the Render Scaling down a notch or 2.

I use 4K at 3840x2160 and because the resolution is that high I don't need the same Render Scaling etc as if I was using 1080p.

Play around with the Render Scaling setting and see the improvement and also see if you can see much if any difference in the visual quality. I can't but my eyes may be a lot older than yours:)

What I can say is that my PC specs are similar to yours and I can fly London landmarks & EGLC in the stutter free high to medium 20s fps at the densest part of London, which makes me think it is a graphics setting issue.

I use  Ultra and then make custom changes to unimportant aspects of that setting which are unnecessary due to my monitor resolution. Things like AA can be toned down as it is not required to be at the highest setting when running 3840x2160 screen resolution.  Shadows can be one click lower than Ultra etc.

Also try at test without any AI traffic running and see if the combination of customising your Graphics settings results in a better performance without any noticeable degradation of visuals

Link to comment
Share on other sites


 I have nearly the same pc specs as yourself with a 30Hz monitor. Stuttering was cured by enabling G-Sync in display settings AND setting the FPS to 60!!! Doubling the fps to twice that of the native refresh rate of the monitor sorted it out for me. Why I dont really know as all I read pointed to G-Sync not working properly. Also try flying with a non glass cockpit airplane like a Cub as glass cockpit planes are still buggy. Another common one is to exclude your FS folder and sub folders in you anti virus program.

Hope this helps a little.


Link to comment
Share on other sites

Hi guys, 


First, thank you for your suggestions. Lowering the render scale was something I tried, down to 50, which is not from this earth, and it did not help. I enabled G-Sync as well, and tried to limit the FPS at various stages.

I do not think this is a hardware problem, first because when I disable the scenery everything is smooth (although lower than 30 FPS) even on Ultra. Second, New York should contain much more information to be loaded on my GPU with photogrammetry on, on the `high-end' settings, and I have no stutters as you can see in the video. Even when using an airplane with a glass cockpit.

Link to comment
Share on other sites

Please note that this is a demanding area and the issue you are experiencing is not generally being reported by others. This leads me to think that it maybe something your end despite your high end PC specs.

If it was a product fault it would have been resulting in many reported performance posts on this forum.

I am not dismissing the issue just explaining that it appears to be affecting you rather than others.

Link to comment
Share on other sites

Hi Jon,


Thank you for your attention! I have tried something new. I had the scenery installed in a "Library" Folder, using Orbx Central automatic settings, just like I have for x-plane. I uninstalled the scenery and re-installed it directly to MSFS installation folder and the issue seems to be gone. I could run it between 30-40 FPS with a few settings in Ultra and other is High.


What bugs me is that the Orbx Library is also in an NVMe drive, the same as MSFS in installed. I did that only for organization purposes, the same way I do in X-Plane without any issues (including True Earth GB), and a couple of other MSFS airports that I also have from Orbx are in the external library folder and I don't have any issues like shown in the video. 

Link to comment
Share on other sites

I am glad it is fixed Gabriel.  We are all learning new things about the sim every day and many nuances appear to be only related to an individuals set up and not affecting everyone. In your case, the sim did not appear to like the fact your addon was not in the MSFS installation folder but outside it in a library.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...