Jump to content

Nothing can be installed or updated


Recommended Posts



I recently purchased Gothenburg,I opend FTX Central 3 to Install it and was forced to uninstall FTX Central 3 and downloaded the new Central,I logged into my account and went to install it and got This Error,I tried my other products that was not installed yet and same thing popped up. (Could not download and save the manifest). Also Got a notification saying two updates required but when i checked for updates,nothing is outdated.





Operating system:  







Link to comment
Share on other sites


 Do you have these requirements installed that are outlined in the user guide linked below, and can also be found under settings/help/user guide?



System Requirements


Windows 7 SP1+, Windows 8.1 and Windows 10 are supported. The following components need to be installed for Central to function correctly:



Additional Requirements for Windows 7 and 8


Link to comment
Share on other sites

  • 2 months later...



im facing the same issue


so far i have tried


disabling the anti virus

execute as administrator

clean re-install

manual download

reinstalling the components linked above but so far nothing achieved...


here under the copy paste of log


2020-02-22T16:34:21.735Z [INFO] [Central::InstallationService] - Beginning installation of Orbx Libraries
2020-02-22T16:34:23.223Z [DEBUG] [Central::InstallationService] - Installing to C:\Users\MIGS\Desktop\X-Plane 11\xp11\Orbx Libraries
2020-02-22T16:34:23.700Z [DEBUG] [Central::SimulatorService] - Using simIsRunningCache
2020-02-22T16:34:23.701Z [DEBUG] [Central::InstallationService] - Validation: Actions are allowed.
2020-02-22T16:34:23.701Z [DEBUG] [Central::InstallationService] - Validation: Library is ok.
2020-02-22T16:34:23.702Z [DEBUG] [Central::InstallationService] - Validation: Simulator is ok.
2020-02-22T16:34:23.702Z [DEBUG] [Central::InstallationService] - Validation: No antirequisites found.
2020-02-22T16:34:23.703Z [DEBUG] [Central::InstallationService] - Libraries has 0 prerequisite(s).
2020-02-22T16:34:23.866Z [ERROR] [Central::InstallationService] - self signed certificate in certificate chain
2020-02-22T16:34:23.867Z [ERROR] [Central::InstallationService] - {}
2020-02-22T16:34:23.867Z [ERROR] [Central::InstallationService] - Could not download and save the manifest.
2020-02-22T16:34:51.611Z [DEBUG] [Central::SimulatorService] - simIsRunningCache has been invalidated.
2020-02-22T16:36:28.666Z [INFO] [Central::InstallationService] - Checking for outdated products. Found 0.
2020-02-22T16:39:46.091Z [DEBUG] [Central::SimulatorService] - Not using simIsRunningCache
2020-02-22T16:39:46.091Z [DEBUG] [Central::SimulatorService] - Setting simIsRunning cached value.


please im quite upset with this any help is appreciated



Link to comment
Share on other sites

On 2/25/2020 at 11:23 PM, Nick Cooper said:

Hello douh,

you can find it on the "My Account" page in Orbx Central.



 still the same... :( as always i deactivated anti virus, windows defender, and started the program as administrator







Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...