Jump to content

The Central downloader has a flaw


Recommended Posts

Hello, I can't get the Orbx Central downloader to work and I think my findings deserves a topic.


I have run Linux ever since I could build my own PCs and it said "Use Windows 98ME or better", so, Redhat then..


When I run Orbx Central I'll get two "dangling" symlinks, the SingletonCookie and SingletonLock. They appear red in Midnight commander and they point to files in the same folder that aren't there. Are they supposed to be this way?


I've tried to install all of Great Britain for three days (Great Britain South ID: 61a17583b18fe) though my log contains what came out when trying to install the Monument Valley.


Would someone look at my log, when it's trying to download sceneries the servers appear to have moved. When I try to hand download some files they give me the 301 error which tells me something doesn't add up. There are several hundred files for Great Britain and if I did get them what would I do with the files? I would also have lost my will to live, I think there are 800 downloads in total and the server isn't "there".


The folder blob_storage is interesting, my home folder doesn't have plenty of space so the Central folder inside Orbx had to go in a symlink on the same harddrive as the Orbx library so my home folder doesn't run full. Because of this I've made a fresh profile in case that wasn't the way to do it: I've secretly renamed the main library, started the new profile, quit Orbx Central and renamed the library back. At the next time Orbx Central started it had accepted all the library as it were. I could download single files using wget that works just fine but I don't have the foggiest idea where to put them.


I have lots of ways to analyse the logfile but I won't go into boring details, though I'm curious about the 301 error. If I should adress a new server where do I make the change, or does it mandate a new release of the Central downloader?


I've purchased sceneries for north of $AUD 200 just this week and I think I can find a way to install the Monument Valley scenery. The C90 at Sedona is lovely in the morning. Would Monument Valley also work on top of the other ortho scenery?


I've been good with software since the early KDE days (lol I'm Norwegian so KDE is close to my heart..) and I won't shy away from a little poking, but the Central downloader is a private piece and I could well leave it alone. It's a pity though about all my purchases gone to waste.



central.log scenery_packs.ini

Link to comment
Share on other sites

Guest Josh Koz

Hi @NorskRoger

A 301 Redirect isn't an error but a HTTP status code to tell the downloader to redirect to a CDN Point of Presence that is geographically closest to you. If you had tried to download one of the product zip files on the command line using `curl`, you'll find you'll need to use the '-L' flag to ensure that the redirect occurs and the file downloads.

An error that does appear in your log file when attempting to download a file is the following:


2021-11-29T08:42:51.707Z [INFO] [Saturn] - Retry Limit reached when attempting to download chunk 719cdf53-5459-49cf-be26-45bba3525e4d. The SSL connection could not be established, see inner exception.

Can you try starting Orbx Central via the command line with the `strict-ssl false` flag and seeing if it has an affect?


./Orbx\ Central strict-ssl false

Can you also check that you have the latest trusted root certificates for your distro installed? For ubuntu the command is `sudo update-ca-certificates`.

Link to comment
Share on other sites

Hello, thanks, I run Gentoo as my daily driver and my distro has to fetch source files for updates and it works just fine.


For fun I have Manjaro on the same nvme which also sets the grub,  I like the boot screen.


I can also tell you that the ca-certificates has opened a bug as a quest open the newer versions for "clean" systems. I'll need to give a keyword "~amd64" to install any newer version, any keyword with the tilde could have an adverse effect on the stability.


[I] app-misc/ca-certificates
     Available versions:  20210119.3.66 ~20210119.3.71 ~20211016.3.72 {cacert}
     Installed versions:  20210119.3.66(kl. 23.11 +0200 08. juli 2021)(-cacert)
     Homepage:            https://packages.debian.org/sid/ca-certificates
     Description:         Common CA Certificates PEM files


The version 20210119.3.66 is highly visible on the terminal with in inverse and green, much more readable, and the tilde ones are in yellow, so that's being in development.


I'm using wget for my trials, it's probably unwise to poke around like this but it's for problem solving. I know that if I use 'wget -6' it appears to be the same error as in the log and the "/4" in the url appears to be a ipv4 server. I don't have to emphasize 'wget -4' to grab a zip file and it would download just nicely. So I've concluded that the Orbx-central happily tries to use ipv6 despite it's not told to.


I'll try to ask any developer how to go foward with the ca-certificates as I know how to "keyword" the entire system although it's not adviced. It would be nice to get the Orbx-central to work so I don't have to install the sceneries myself. ^_^



There's a new openssl available although version 3 is hard masked. That's Gentoo geek for calling me a wuzz and I'm not having it..


[I] dev-libs/openssl
     Available versions:  1.0.2u-r1^td 1.1.1k-r1(0/1.1)^td 1.1.1l(0/1.1)^td ~1.1.1l-r1(0/1.1)^t [M]~3.0.0(0/3)^t {+asm bindist fips gmp kerberos ktls rfc3779 sctp sslv2 (+)sslv3 static-libs test tls-compression (+)tls-heartbeat vanilla ABI_MIPS="n32 n64 o32" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="sse2" ELIBC="musl" KERNEL="linux"}
     Installed versions:  1.1.1l(0/1.1)^td(kl. 20.09 +0200 30. aug. 2021)(asm -bindist -rfc3779 -sctp -sslv3 -static-libs -test -tls-compression -tls-heartbeat -vanilla ABI_MIPS="-n32 -n64 -o32" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" CPU_FLAGS_X86="sse2" ELIBC="-musl")
     Homepage:            https://www.openssl.org/
     Description:         Robust, full-featured Open Source Toolkit for the Transport Layer Security (TLS)


And the flags didn't do any difference, I'll include the log.




Link to comment
Share on other sites

Yep Orbx Central is not letting me install anything i hit install and nothing happens i logged out and logged back in still can not install anything i hit install it pops up and thats it. I was installing PNW last night and it froze almost to end and stayed that way for hours. don.t know what is going on but its annoying.

Link to comment
Share on other sites

  • 4 weeks later...
On 12/11/2021 at 5:05 PM, NorskRoger said:


Hello, I've fixed the problem myself after the devs didn't respond. Firstly I have Linux only and I run X-Plane.

Please post your solution, I've already confirmed my certificates are updated and my support ticket is not being looked at now after a month of checking been in. Curious to see what you did.

Link to comment
Share on other sites

Yes, I've solved the Gentoo issue itself, as well as the managing of hand installing all the zip files to circumvent the network problem. In this way the installer would discover the zip files on drive and continue to install and not cause any error. For us Linux people there's a bit of a fiddle and the software's Windows heritage doesn't lend itself well to user support.


I've also figured how to copy the profile files to another distro, I have Manjaro on the same drive and it would run wonderfully there.


The real solution with Gentoo was to keyword "ca-certificates-20211016.3.72" and have this installed, one of the files here would be crucial for the Orbx-installer not to crash, what exactly that's going on I can't tell but I've placed special "Roger: not to touch" instructions for the installed file and everything works.


Install the latest ca-certificates you could find for your distro.

Link to comment
Share on other sites

On 12/7/2021 at 12:30 AM, Josh Koz said:

A 301 Redirect isn't an error but a HTTP status code to tell the downloader to redirect to a CDN Point of Presence that is geographically closest to you. If you had tried to download one of the product zip files on the command line using `curl`, you'll find you'll need to use the '-L' flag to ensure that the redirect occurs and the file downloads.


A happy new year, I've found a way to awk and grep the log file to my heart's content to grab the sceneries and the wget didn't need the -L to download. My new 8 TB drive isn't nearly half full and I've transferred the sceneries there post conversion for less fragmentation (if the btrfs really has any). Had I really unmasked this little package I would have saved me all of the 5 minutes of coding exercise.


The Orbx-central (previously called downloader, I'm sorry) is really finicky about the ca-certificate which was previously 3.66, I had to do a little successive unmasking until I've got to version 3.72 (Manjaro shows ca-certificates-mozilla-3.72-1 as well where it does run). Another user (apparently he's had a slow external drive or ioctl bottleneck) can't get past the required version and I'm sorry I can't help. Not that I've got his Linux version, they'll need to help me to help..


I'm really happy I could code myself out of problems, I've felt I was caught with my hand in the cookie jar because, well, Christmas. That said I've got the sceneries I've paid for.



Link to comment
Share on other sites

  • 2 weeks later...

It was Manjaro that solved the problem for me that had the 3.72 version of the certificates. On Gentoo I had tried the 3.71 version (Windows uses a rolling version that I don't understand that casued the problem in the first place).


On Gentoo I had to run a script to grab zip files:


for i in `cat blob.txt`;do wget...


and of course I didn't have the foggiest idea where to have the files. So Manjaro with the 3.72 version of the certificates solved it for me.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...