Jump to content

Product Updates fail

Recommended Posts

Operating system:  Win7 Pro X64

Simulator:  FSXA


Issue:  Updates fail to complete. There appears to be  several 'Fail to copy file' errors and 'UnauthorizedAccessException's noted in the log. I am running Orbx Central 'as administrator'.


When attempting to update various products I receive an error message after the download of the update is comole. (See attached screenshots). The log file seems to indicate a failure to copy a file or files after extraction or a failure to extract all the files in the update.  After each update failure I ran the "Verify Files" procedure as recommended by the error message but that resulted in the same outcome. My VERY slow ADSL2 download speed is only 400 KBs so each attempt to download/update a product such as Global or Vector takes a long time. I have spent hours trying to update those products and aa the airports shown that have updates available. Due to the length of time it takes to download and update for the main products, there is no way I am about to uninstall and reinstall them. The time required would be prohibitive and I am not about to spends DAYS doing that.


I had no problems installing several updates a few weeks ago under the previous Orbx Central 4.1.1. However yesterday I was forced to update that program to 4.1.14 and that appears to have brought about this issue.


The ONLY update/installation  that completed was the Holgermesh for Australia. All other update attempts failed. That includes Global, Global Vector and all the airports that were flagged as having updates available. I have not changed anything in my system since the last time I was able to run updates, other that Orbx Central. I have no AV running and no files quarantined.







Link to comment
Share on other sites

The TEMP Folder is empty as is the Backups folder.


I changed the access rights to all four accounts to "Full Control" and that allowed the updates to proceed but on a few of them I still got the "failed to extract" error message. The version numbers however, did reflect the latest versions. I did notice that on two or three products that had a "Configure" button, selecting that opened a page with no configuration options or information. Could this be the result of a 'failed to extract' situation? KHQM Bowerman configurator simply showed the text "Bowerman Airport", "Control Panel" and the "save Changes" and "Cancel" buttons. Nothing to configure. YPLC - Port Lincoln was the same as was YRED, Redcliffe Airport. Most of the products that I finally was able to update ended with the 'failed to extract' error with various numbers of files shown. I have no indication as to what those files were or how they might affect the products. Early on I selected "Verify Files" when I received that error message but nothing changed. The process ended with the same error message so I stopped even attempting to select that option.


I never had to change the permissions/access rights for Orbx Central before as everything worked as expected with the last version I used, 4.1.10 or 4.1.11.   I'd rather not leave those permissions that allow 'Modify' and 'Write' for "Users" or 'Full Control' for "Users" and "Authenticated Users" which I had set to accomplish the updates based on a recomendation in another thread here that I ran across.





Link to comment
Share on other sites

I was running as administrator.


After digging into the log file I could see where the failures were occuring. I managed to get rid of all the failures by removing the 'read only' attribute for all Orbx files. I even had to do that for files in FSX\Scenery\World\scenery as there are Orbx files in that folder.


For some unknown reason even though I was running as administrator those read-only files were causing Orbx Central to not be able to update files such as all the cpl.xml files.


Nothing on my system has changed since I was able to do updates with no problem back in early May. Only the update to Version 4.1.14 took place.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...