Jump to content

Windows file access error whenever Orbx Central tries to update itself


Recommended Posts

Hello, I have a straightforward Windows 10 installation, with a normal MS non-admin account and a local "Admin" account with administrator permissions.  When installing Orbx Central (as with almost every other app), I run it under my normal account and it prompts me for the Admin password - no problem.  Again, no problem running it like this once installed, so long as it is on the latest version.  But if I run the app and it decides to update itself, it downloads the file and then fails with the attached file permission error.  I get the same error if I explicitly 'run as administrator', and if I try to log in as Admin and run it from there, it (understandably) complains that it can't find a simulator, since I use my normal account for MSFS.

 

It's not a showstopper, as I can always uninstall Orbx Central and then re-download the new version from the website, but it's quite annoying, since I have to do this whenever a new version of the app is available, or I can't run it to manage my Orbx products.  Any thoughts on what setting I need to change on my computer to get this to work properly?  I don't have any problems with installing/updating other apps.  I searched the forum for the error message, but the only thread is this one, and I don't have Avast installed: [resolved] Orbx Central - unable to install by Avast - Orbx Central Support Forum - Orbx Community and Support Forums (orbxsystems.com)

 

Thanks, Jacob

Screenshot 2021-05-02 201834.png

Edited by loge
Link to comment
Share on other sites

The windows account I use to run MSFS (linked to my Microsoft account) is not an administrator, but the local Admin account is an administrator, and the path exists.  I run Orbx Central as my normal account and it then switches to Admin (prompts for password of that user), which is how other installers work fine.  Indeed, the initial Orbx Central installer works fine like that; the problem occurs only when it tries to auto-update.  I tried logging into my Admin account and running it from there, but it complains that it can't find a sim (since I don't have MSFS installed under that account) and quits before getting as far as trying to update itself.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...