Jump to content

Orbx Central cant be opened on Mac


Recommended Posts

This isn’t just an Apple problem, it happens with quite a few programs. You should still be able to open Central. If you google there are plenty of answers along the lines of: 


Here is a quick two second fix on How To Open the Software that throws “Can’t Be Opened Because Apple Cannot Check For Malicious Software” Error

Open Finder

Traverse through to “Applications” Folder

Highlight the software you are trying to Open

Press “control”

Right “Click” & Select “Open”



Alternatively right click on the App; I believe that also works. 

Link to comment
Share on other sites


please attach a copy of the Orbx central Log.

The usual cause of this type of problem is a lack of free space on a disk.

That might be either on the system drive or the destination drive.

Orbx Central allows the temporary files location to be moved and the

customer decides where to install the simulator or the Orbx Central Library.

Link to comment
Share on other sites

On 2/7/2021 at 2:33 PM, Hellsfish said:

Having got it to open I tried to download Southern England and if freezes at about 95%. Tried it twice and left it overnight to download, same problem.


This stuff just isn't fit for purpose.


Anyone tell me how to get a refund?

I hope you get it sorted. Trust me, It really is fit for purpose and does work well on the Mac, particularly the TE scenery. In addition to the Central Log Nick asked for, it would also help to know the type and spec of the Mac you are trying to install this on. 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...