Jump to content

Orbx Libraries update stuck in "queued"

Recommended Posts



Operating system: Windows 10 Pro (1903)

Simulator: Prepar3D 4.5 (




Orbx Libraries will not update via Orbx Central. I pressed the update button and the download began and appears to have completed. The download completes around 80% of the progress bar and then displays the following message: "Finalizing and Cleaning Up - Running after-install actions". After a few minutes the update status changes to "Queued" for what appears to be an indefinite amount of time (I sat for 30 minutes and nothing had changed), this is accompanied with an 'indeterminate' progress bar.


Following along with other forum posts that appear to have had a similar issue, I attempted to check for the Read Only flag on the OF_Config.xml file, Read Only was off. I also attempted to delete OF_Config.xml and then performed Sync Simulator in Orbx Central (Settings > Help), this action completed successfully but the original update issue is continuing to occur.


Any assistance is appreciated.







Link to comment
Share on other sites

Hi Adam,


It looks like the Orbx Libraries install completed correctly, but then our download component crashed before it could report the successful status to Central itself. This would cause the update to appear stuck in queued (when it had actually completed).


Have you tried completely closing Central down (right click in the notification tray near the time, then select quit):



After that, when you next start Central, it should pick up the queued job and complete it (hopefully instantly).


If that doesn't work, please attach a new copy of your central.log file so we can keep diagnosing the issue.


Link to comment
Share on other sites

  • 4 months later...

Hi My Name is Robert McCue 



I just tried to update Orbx Libraries and have the same problem as above.


I have a 2.4Gz CPU, Windows 10 16 GIG Ram, NVIDIA Geforce GTX 770M, FSX Steam

Attached is my Central.log

Any help will be appreciated, I Have Tried Ben McClintocks Suggestion, I have uninstall the reinstalled the Libraries Still No Joy


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...