Jump to content

Orbx Central disappears

Recommended Posts

Hello Team and members,

every time when I want to start Orbx CENTRAL, there is only a very short view on the startsite of CENTRA Lthat shows the Version number and the remark "launching" and then it disappears quickly from my monitor.

Only at the taskbar I can see the little picture of  CENTRAL and I can choose there  beneath the little picture to close the program, that is nowhere shown on my monitor.

So I can´t install neither deinstall anything of my numerous Orbx-Products.

What is wrong and what can I do? Please help me - I want to fly.


Captain Thomas










Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  





Link to comment
Share on other sites


you need to open Windows File Explorer and navigate to C:\Users\your user account name\AppData\Local\Programs\Orbx-central\Orbx Central.exe.

Right click on Orbx Central.exe and from the menu, select "Send to\Desktop (create shortcut)".

You could also click on "Pin to Start", then you will have two means of starting the program.

If you can't see the appdata folder, amend the Windows File Explorer View settings to "Show hidden files, folders and drives".

Link to comment
Share on other sites

Hello Alox,


thank you very much for your help - but this doesn´t work. Sorry!

I tried your instruction for several times. The only succes ist to have one more icon of Orbx CENTRAL on the screen.

I only see for a half second is "Connecting" and then the opening picture disappears.

IMHO CENTRAL is working in the background, because I can see the little picture of active CENTRAL after clicking the little icon at the taskbar and there I can close it.

A few minutes before writing this information to you, i got a information, that CENTRAL has just updated some of my sceneries. But I can´t still see CENTRAL.

I´m worried.




Link to comment
Share on other sites

Hello Nick,

I´m pleased and proud about a really member of the Orbx-Team takes care on my problem. Thank you very much!

I´m really sorry, but I cannot reach the screenshots in your post above. Np way to come there. I´m using WIN10 64 with newest updates, the last driver-update of my Geforce GTX 1080 TI and a CPU INTEL  I7 8700K. I´m using three Monitors for Panel and surrounding and one Monitor for Navigation (FS-CONTROL)


I´ve downloaded Orbx Central 4.1.13 a few days ago and since that time I have the problems. With Version  4.1.11 it was all alright.



Captain Thomas

Link to comment
Share on other sites

If you cannot see the pictures, please take a look in the lower right hand corner of your PC screen,

probably in the "Show hidden icons" box.

You should see there the Orbx icon.

Right click on it and select "Show window".

Orbx Central should then appear on the screen.

Click on the Settings icon, the toothed wheel at the top right, select General and uncheck the two

boxes, "Minimise to system tray on close" and "Start on system launch".


Link to comment
Share on other sites

Hello Nick,


a great thank you for helping me. This was the right hit - the problem is solved and I can work with CENTRAL. I have deinstalled  some damaged Orbx-sceneries and did some reinstalls. Now my PREPAR3D v4.5 and PREPARED3D v 5 work both with all my Orbx sceneries in a good way. Thank you!


The reason of the damages? Maybe a new Win10 update and the installation of the newest driver für my graphic card GTX 1080 Ti at the same time. I don´t know. But now I´m happy to fly.


Greetings from Germany EDPA and EDDS.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...