Jump to content

Problems updating

Recommended Posts



Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  Win 7 64bit

Simulator:  P3DV4.5


Issue:  Problems updating

I seem to have 2 updates available, but trying to install I get an error message being :
A communication error occurred when trying to perform this action.
This error appears using the Central or going throught the website.
Can you help me out here please?
Thanks, John.





Link to comment
Share on other sites

Hi Nick,

Thanks for the rapid reply, sadly enough, after installing the ones that weren't installed already (or even newer versions) same error occurs.

I downloaded (bought) LDDU airport yesterday, no problem. Then noticed possible updates for Global Base pack and object flow.

Still the same, sorry. Are there any other suggestions I can try?

Thanks, John.

(I used my second e-mail address to be able to reply...argeon1@live.be is my account inlog)


Link to comment
Share on other sites



I have just been experiencing the same problem as you. I followed the advice given by Nick to no avail, tried turning off antivirus and firewall - again to no avail.

As a test, I uninstalled Orbx Central (just Central, no scenery packages) and did a new download and installed.
The updates worked straight away without having to turn off antivirus etc.
I noticed after, that despite trying the 'check for updates' for Central in the settings tab, it wasn't seeing that a new version 4.1.11 was available - it kept saying that 4.1.10 was the latest, which I'm guessing is why the hangup occurred.

Hope this helps?
Best regards

Link to comment
Share on other sites

  • 1 month later...
Guest Josh Koz

Hi @Argeon


Can you try attempt an install, update or verify files to encounter this error, then reattach your central.log file? This should hopefully result in the log file capturing more detail about why you're encountering this issue which we can then investigate and attempt to resolve.


Common reasons for the error in the screenshot are missing requirements or anti-virus incorrectly quarantining the the Central worker process.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...