Jump to content

Orbx Central 4.19 hangs at Loading Products and Librairies

Recommended Posts



Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  Windows 10 (installed last week by professional IT)

Simulator:  X-Plane 11.50 + FSX-SE + Aerofly2


Issue:  Orbx Central 4.19 hangs at the black Loading (products and libraries) Screen.  Have uninstalled Orbx Central  - via Control Panel unistalll  programs -  and rel-installed etc but with same result. Was working fine until yesterday. I was relaoding products, after Windows 10 update from Win 7 last week, over weekend.


Broadband speed test approx 70Mb/s.


Please help!





Link to comment
Share on other sites

Seems to have remedied problem by deleting appdata AND Orbx-central-updater as wel as unistall - then reinstall.


Only problem now is Central is not picking up FSX - just the X-Plane and Aerofly2 --  any ideas on ho to add FSX to Central much appreciated.


Still not sure what went wrong initally however.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...