Jump to content

Central v4.1.1 does not see P3D v4

Recommended Posts

I seem to have the same issue with P3D. I ran through the suggested video mentioned earlier in this thread and checked the control panel showing all is OK, but I still cannot get Orbx Central to find P3D in the top display, it shows Aerofly FS2 and two lines of X-plane 11 but no P3D.


I tried downloading some of my previous P3D products vie Orbx web site download but they have a suffix c4 with example file name global-base-8d985ef7-6e61-4802-82b4-8f5c9a47f1bc.f.c4


Due to a very slow Internet service in country Qld it took some 24 hours to download just 5 of the twenty or so products for P3D. 


I did a manual download because Orbx central could not see any P3D stuff.


In Orbx central only X-Plane and Aerofly FS2 show up my products, nothing for P3D


Most P3D  Orbx orders were transferred to Orbx when FSS stopped selling Orbx products in 2015. The FSS order number for Global Base is 347666 and all P3d products were purchased from them but Orbx confirmed they has received the records and they are now registered with Orbx.


All my purchases for all three simulators are shown in my Orbx website account orders list. 


Please advise how I can get these product downloads (24 hours work already !) installed.




Colin Rayner



Link to comment
Share on other sites

  • Nick Cooper changed the title to Central v4.1.1 does not see P3D v4

Hello Colin,

I have split this from the other topic.

Orbx Central needs there to be a P3D v4 registry entry and it must point to where P3D is installed.

That location must contain Prepar3D.exe.

If either of these conditions is not fulfilled, Orbx Central will not see P3D v4.

Here are some illustrations:








This is where Orbx Central is looking:



"currentSimulator": {
    "base": "esp",
    "name": "Prepar3D v4",
    "abbreviation": "p3dv4",
    "abbreviationDownload": "p3dv3",
    "executable": "prepar3d.exe",
    "rootPath": "G:\\P3D v4\\",


Link to comment
Share on other sites

Thanks Nick, it seems I had done everything OK but . . . .. . I started the system this morning and all was Ok . . it seems I needed a reboot to get P3D registered. Imagine that. 

The only downside is that the 24 hours downloaded was probably a waste of time !


However your details saved me heaps of effort so thanks for that.


Now to start the long journey to downloading all the stuff again, not just to restart P3D V4 but also to be ready for P3d v5 at some time later when it is well tested.


Hopefully I did not waste too much of your time.


Regards from Oz

Colin Rayner

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...