Jump to content

Orbx Central Not Displaying On Screen

Recommended Posts

Operating system:  Windows 10

Simulator:  P3D v4.5

Screenshot:  N/A

Issue:  So this is a new weird issue I'm experiencing with Orbx Central. I've purchased the remaining NA scenery libraries yesterday through the web browser interface and was going to install them today. However, Orbx Central will not show on screen. It will load the splash screen which is shown on screen, but once loaded, the application itself remains hidden.


This is what I've tried so far with no success in resolving this issue:

- Shift + right clicking on task menu application will not load a Move/Maximize menu (it won't give me any options)

- Right clicking on the Orbx Central task menu item gives me 3 options, Orbx Central, Pin to Taskbar, Close Window. When I click on Orbx Central, it will show a command prompt like black window box for a split second then disappear.

- Enabled all monitors to see if it was hidden elsewhere, it will not display on any of the 3 monitors.

-- Tried using extend screen, duplicate, pc screen only; nothing works.

- Right-clicked on the Taskbar and clicked on Cascade Windows.

- Disabled Tablet mode, and confirmed Desktop Mode selected, then a reboot.

- Tried uninstalling, then reinstalling Orbx Central application, but gives me the same behavior.

- This only affects Orbx Central, and no other application.

- Confirmed that all Window Updates were applied.

- Restarted Windows Explorer in Task Manager

- Rebooted PC


Unfortunately, none of the above worked. What's interesting is, that when I hover over the Orbx Central task menu item, I can see the application display in the task menu, but it won't extend to my screen. Task switching also shows the application, but won't display to screen when selected.


Windows 10 is a fresh install from over a week ago, and Orbx central was working fine days ago. I would really like to install the newly purchased scenery libraries to complete my NA collection. Any help would be greatly appreciated.




Link to comment
Share on other sites

Can disregard this post, using the following method worked for me. Appears to have been an issue with Windows 10 displaying the application. Not entirely sure why, but hopefully this will be helpful with anyone else experiencing the same issue.

The Hotkey Alt-Spacebar

Try holding Windows Key + Shift and then press left arrow key 2 or 3 times, if this doesn’t work then try again with the right arrow key instead.


Would it be possible to allow for a Shift + Right Click on the Orbx Central taskbar item which will allow the Move/Maximize menu options? With flight sims commonly running multiple displays, might be good to have in case this issue reoccurs.

Link to comment
Share on other sites

Hi Doug,


I checked it even. I found two options: 1. Open Orbx Central    2.  reset window position  - under Option 1 I get the same result as I click on the Orbx Central Icon on the taskline -- nothing - under Option 2 I get a ERROR Message (see below).


I hope Orbx will update Orbx Central (I worked nearly daly with it anto, this ERROR)





Link to comment
Share on other sites

18 hours ago, SeaToSky said:

That's a good call out Doug, I didn't even consider the fact that it was in the bottom right task bar. If it happens again, I'll double check there. Thanks!


You can also go to settings/general and set your preferences.

Link to comment
Share on other sites

  • 2 weeks later...
On 3/30/2020 at 5:41 PM, Doug Sawatzky said:

Can you find the Orbx Central icon in the taskbar and right click on it as in the below image? the Orbx Central icon is under/behind the word "Quit" in the below image.


I had to same issue happen to me again today. It seems to happen every time I purchase a product on the web site, and not in Central. Unfortunately, Orbx Central icon does not show up in the taskbar.

This once again worked for me:

Try holding Windows Key + Shift and then press left arrow key 2 or 3 times, if this doesn’t work then try again with the right arrow key instead.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...