Jump to content

Orbx Centrl 4.1.1 can't install


Recommended Posts

Operating system:  Windows 10

Simulator:  Prepar3d v4.5 Hotfix 2



Good evening all,

I have search long and far for hours with no success. I don't have central 3 anymore as I cleaned it out not even think that I didn't have Orbx central installed. I went to install it and like others, I have this 25% loading issue. Yes, I have checked the manual. No, I cannot find a log file. I'm not too sure what the issue is with this not wanting to load. I remember when it first came out I had it, but installed it for some reason during a PC cleanup session that I have a few times a year, as all simmers do. If there's any suggestions, please help!


What I've tried:

Updating Visual C++ 2015, 2013 -- both are updated as of March 2020, so there's no conflicting things there (hopefully)

Log files: searched for log files before cleanup and there were none, searched far, far, far and none.

Tried rolling back computer for updates or any major changes, nothing.



Thanks fellas!








Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...