Jump to content

Central v4 doesn't work with FTX Central v3 Installed !

Recommended Posts



Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  Windows 10 64x

Simulator:  FSX Steam


Issue:  Today, after buying a new product from OrbX (//42 - precipitFX), I tried to download by FTX Central V3.... it appears but I can't download it. Searching on Forum, I realized that I should use the new Central V4 version. After installed this new version, my login and password weren't accepted. I realized that FTX Central V3 was still active and logged on OrbX. Even after logging out on FTX Central V3, the new version continued not accepting my login (and even after reinitializing the PC and FSX Steam).

I tried to uninstall FTX Central unsuccessfully. How do I do to uninstall the old version (there is no uninstaller) and install the new one without damaging my OrbX libraries already installed, and also installing my //42 - precipitFX acquired on OrbX (can I download it manually)?

Since now, I thank all the help provided.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...