Jump to content



Recommended Posts

I tried to uninstall GB South from my xplane 11 and it wont allow me to.  I get an error message.  I tried to Verify the files, but get an error message.  I attached a screen shot of the error message I get when I try to uninstall.  Anybody know what is going on?

Great Brittan South.PNG

Link to comment
Share on other sites


I will be interested in the outcome of this, as I have another request with the same problem.

I have asked the developers to take a look tomorrow.

Please attach a copy of your central.log file for them.

Tomorrow in Australia starts at around 2100 hrs GMT, in around four hour's time

Link to comment
Share on other sites

Thanks, but  log.txt is not the same as central.log.

this is from the developers:





Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations:

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log

  • Linux: ~/.config/Orbx/Central/central.log

  • You can also find it in Central on the Settings page, under Help



Link to comment
Share on other sites

Guest Josh Koz

Hi @yakuba,


Thanks for providing your central.log file.


The issue appears to be that you a a library set up in Orbx Central that doesn't have a path set. 

2019-10-30T15:14:36.482Z [ERROR] [Central::LibraryService] - Library integrity check failed for Library Main Library (undefined). Error: Library path does not exist


I'd suggest first removing this library through the Settings > Libraries. Then closing Orbx Central completely (ensure it's not running in the system tray). 


On the next launch you may find GB south isn't marked as installed. Clicking install will scan through, see that the required files are in place and mark the product as installed. You'd then be able to uninstall it correctly if you so wish.


Link to comment
Share on other sites

Guest Josh Koz

Hi @yakuba,


In this case you'll need to delete the broken library out of your settings.


  1. First close Orbx Central and ensure it's not running in your system tray.
  2.  You'll need to open up your central settings file. It can be found at the following location
    • %APPDATA%/Orbx/Central/central.json
  3. Inside will be a section called libraries. I've attached a screenshot of the libraries section in my settings file for reference.
  4. You'll need to delete this libraries section then save the file. 
  5. Relaunch Orbx Central and readd your library back. You shoudn't encounter an error this time.




In a upcoming update of Orbx Central we adding some guards around libraries to ensure they don't accidentally get created when they don't have a path set to prevent this error from reoccurring.


Let me know if you run into any issues with the above steps.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...