Jump to content

Missing Sceneries


Recommended Posts


Operating system:  Win10  1903 / 18362.356

Simulator:  P3dv4.5 w/ HF


Issue:  Missing Sceneries


I have noticed that I have several missing ORBX sceneries from my scenery.cfg file.  It started with noticing YBCS was not showing in sim, but, seems to include other areas as well (NZNI, NZSI among others).  Because I have so many ORBX sceneries it is hard to get a total count.  The proper folders exist in the ORBX directory populated with what appears to be all the files.  Recently purchased sceneries are showing fine. 


I have tried numerous things (please note the sceneries / areas all do show in My Products):

  • Running old FTX Central v3
  • Running ORBX Central (4.0.13) and choosing Sync Simulator, including the advanced insertion option
  • Verify Files
  • Uninstall / reinstall, including deleting relevant folders and download backups to force a fresh download, then resyncing
  • using a fresh regenerated scenery.cfg (attached), then resyncing


Nothing seems to work.  


One issue I see is that the sceneries that are missing seem to also be missing a xxxx.json file in the P3D/ORBX/Config folder.


Very early when ORBX Central was released I had originally tries to Migrate to Library my entire collection, but, reverted when there were issues at the beginning.  I re-downloaded and re-installed everything, and the missing sceneries are not present in the library.


Any help resolving the issue is appreciated.

central.log scenery.cfg

Link to comment
Share on other sites

This problems is driving me insane.  I identified at least 5 airports and 4 regions that are affected.  These are purchased and show as such in ORBX Central, but, will not be entered into my scenery.cfg.  I managed to fix two (LOWI and 3W5) by redownloading.  Two others were fixed by uninstall then reinstall into a library (not my preferred choice).  These were YBCS and KACK.  I have done anything on regions yet (CRM, PFJ and both NZNI and NZSI).


The last airport is showing some very disturbing behavior - 1WA6.  I tried the migration route which almost worked except for missing runway textures.  BUT, I noticed something very odd.  I uninstalled and reinstalled many times, from back ups, online after deleting backup, and via manual download.  When installed into P3Dv4 folder there are less bgl files than when installed into library.  This is repeatable (pictures attached).


I hope as the weekend ends and  Monday rolls around I can get some support - thanks.  As a note I also tried uninstalling ORBX Central and doing a fresh download and install.  I have since removed FTX Central as well.  I have verified Central and Saturn are excluded from by AV (default Win10 Security).


First picture is scenery folder when installed into P3D , second when installed into library - 21 more files present.  Texture folders show a difference of 10 files.


P3d Folder.JPG

Library Install.JPG

Link to comment
Share on other sites

Hi Joe


Just a couple of points to clarify for you. You seem to be using two different install methods with different file structures and expecting to see the same result.


When you install a product into a library outside of the simulator, it is installed via the .xml method and will not display in your scenery.cfg and will show additional files because they are not placed in the same location. This product will show in your P3D addons list, not the scenery.cfg.


When you install a product into the simulator folder, it will display in the scenery.cfg, and will also install files and spreads them around to the sound, effects, world scenery, etc folders which is a different file structure than the .xml method.

Link to comment
Share on other sites

No clarity needed - quite very aware of that, however, the "missing" bgl files are not present anywhere else when installed via the P3D / scenery.cfg method.  This is via a search of the entire system.   I also tested by adding the folder manually to my scenery.cfg and it was a mess that did not work.  Again - this is using the install to P3D folder method not to library.


Furthermore, pointing this out because as I tried to say - nothing is added to the scenery.cfg when using the install to P3Dv4 folder as the method.  1WA6 is not placed in the scenery.cfg - at all - and of course does not show.  To be clear this is when choosing the appropriate method of installing to the P3Dv4 folder, NOT library.  Same for the other items I mentioned.


For the record I just installed FSX/Steam, then installed 1WA6 as a trial and it installed fine with the same 35 files that show in the Library method.

Link to comment
Share on other sites

Hi Again Doug - yes I have.  No joy.


The airports / areas in question will not add to my scenery.cfg at all (again - choosing appropriate method without doubt).  I also totally uninstalled ORBX Central and reinstalled.  I also did manual downloads and made sure the relevant backup folder was removed on several.  As I mentioned in my first post I also tried a fresh, bare bones regenerated scenery.cfg (which is attached above).  I have verified files more times than I can count.


The problem is relatively new as I just purchased 1WA6 a few months back and it was fine, and, I flew out of YBCS in the last few months as well.  I know all was fine pre-ORBX Central as I had several old scenery.cfg backups from various points where YBCS, 3WA5, KACK, LOWI, CRM, PFJ, NZNI and NZSI were all properly present.  I even tried manually adding some of these back in, but, as soon as I run ORBX Central again those are removed from the scenery.cfg again.

Link to comment
Share on other sites

Guest Josh Koz

Hi @JPL19


Thanks for providing your central.log file. I believe you're encountered an issue that we've currently been tracking and are in the process of fixing.

The error in your log file that points to this issue is the following.

2019-09-20T17:16:13.717Z [INFO] [Saturn] - System.UnauthorizedAccessException: Access to the path 'D:\Lockheed Martin\Prepar3D v4\Effects\texture\Thumbs.db' is denied.
2019-09-20T17:16:13.717Z [INFO] [Saturn] -    at System.IO.FileStream.ValidateFileHandle(SafeFileHandle fileHandle)
2019-09-20T17:16:13.718Z [INFO] [Saturn] -    at System.IO.FileStream.CreateFileOpenHandle(FileMode mode, FileShare share, FileOptions options)
2019-09-20T17:16:13.719Z [INFO] [Saturn] -    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
2019-09-20T17:16:13.719Z [INFO] [Saturn] -    at Saturn.Jobs.Install.MainSubStages.ExtractSubStage.ExtractChunk(InboundChunk chunk)

The issue is that there are a few products that incorrectly contain a Thumbs.db file in one of there zip files. Upon downloading and extracting one of these zip files, a permission error occurs and the rest of the files inside that zip aren't extracted. This results in the strange issues you're encountering.


Fixing this issue requires us rebuilding a number of products that contain this issue. We're hoping to complete this process by next week. We're releasing an in place fix today for NZNI and NZSI which should resolve the issue with these airports. Verifying these products will resolve this issue once this fix is released.

Link to comment
Share on other sites

Hi Josh - thanks for the explanation this was driving me nuts.  I see already this morning (for me) it looks as if NZNI and NZSI installed ok.  The only ones lingering for me are PFJ and CRM.  I migrated several airports, but, did not want to do that with the regions.


Again, thanks to you as well as Doug for jumping in.

Link to comment
Share on other sites

  • 2 weeks later...
Guest Josh Koz

Hi @JPL19


Just following this up. We've rebuilt all products that we've identified to have the thumbs.db issue. Feel free to perform a 'verify files' to extract any missing files on your products.

Link to comment
Share on other sites

I have a similar issue with ybcs.


I have rebuilt my machine, and using Central 4.015 I have installed everything so far into the main p3d folder.


I have downloaded ybcs a few times, verified files, synced the simulator, and it does not appear in my scenery.cfg.


The time stamp of scenery.cfg does match when ybcs has been downloaded and installed but it does not appear in the file.


Before downloading I also delete the backup folder for ybcs.


Can anyone help please?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...