Jump to content

Sync Simulator P3DV4 Problem with central 4.0.6

Recommended Posts


You find attached new log,


I tried to uninstall and reinstall central orbx but it doesn't change anything when I want to sync simulator impossible the same error.

So when I configure vector after installing a new scene, I want to sync simulator for textures and always error mesage.

Is there an ORBX technician to help me?


Link to comment
Share on other sites


I looked at the logs.

I found this error message:

 - System.NullReferenceException: Object reference not set to an instance of an object.


I think the error is in the addon.cfg

because when I use sync simulator, the addon.cfg file is the only one that is modified in terms of time and date


but normally, the scenery.cfg should also be modified?


you should know that with ORBX central V3, I had my ORBX files in the p3d directory

with ORBX central V4 I still have my files in p3d I didn't migrate and it works very well


but I had to create a main directory in "user/document/orbx" but there is nothing


I really need help, I can't sync simulator with the textures in p3d anymore


in the addon.cfg I have 2 lines that I had never seen before...

PATH=C:\Users\LOIC\Orbx Library\p3dv4\Orbx ObjectFlow
PATH=C:\Users\LOIC\Orbx Library\p3dv4
TITLE=Orbx Main Library



but in the scenery.cfg file I don't have any objectflow declared is normal?




central.log add-ons.cfg scenery.cfg

Link to comment
Share on other sites

49 minutes ago, Loïc Lourdel said:

but in the scenery.cfg file I don't have any objectflow declared is normal?


That is normal, ObjectFlow uses the add-on.xml system so it will be placed in add-ons.cfg instead of scenery.cfg.


I've tried replacing my scenery.cfg with your scenery.cfg file and it appeared to work okay on my end. Which location did you copy that scenery.cfg from?


This may be caused by a duplicate scenery.cfg file in one of the following places (if you copied it out of ProgramData):

  • %LocalAppData%/Lockheed Martin/Prepar3D v4
  • %AppData%/Lockheed Martin/Prepar3D v4

Does another scenery.cfg exist in any of those two places? If not, we'll add more troubleshooting information in the log for the next version so that we can narrow down the cause of this.

Link to comment
Share on other sites



my scenery.cfg and my addon.cfg is here :

C:\ProgramData\Lockheed Martin\Prepar3D v4



I just have folder: controls, effect, shaders

C:\Users\LOIC\AppData\Local\Lockheed Martin\Prepar3D v4



I have scenery.cfg (it is empty)  and addon.cfg ( i have scenry: UK2000, FSdreamteam, flytampa)

C:\Users\LOIC\AppData\Roaming\Lockheed Martin\Prepar3D v4





Link to comment
Share on other sites

  • 2 weeks later...

This was my problem too.........thanks for the heads up and the comment from Nick. I have had a support ticket in for over a week, saw this, checked my files and found the offending file as above and bingo...fixed! I will note it against my ticket, one task less for the support crew.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...