Jump to content

Unable to download Global open LC Europe


Recommended Posts

Having installed Global Open LC Europe (worked fine ) got an update to do but it failed and I got notice which I have to put on the forum . Uninstalled  GOLCE and tried to reinstall got the same notice . Which I have  included. 

Please help.



Link to comment
Share on other sites

Hi John, welcome to the forums,


Please try this,

Your simulator and all other programs need to be closed first, make sure your antivirus is not blocking it and your UAC is turned off, then try the below procedure.  Also be sure to have HD free space(temp folder) on C:\ that is at least two times the .zip file size so the product can download and extract itself.

Go to FTX Central 3 Settings.

Uncheck the “Use multiple threads for downloads”.

Click on the “Clear Temp” Button.

Click on “Save”.

Restart FTXC3, and try again.


Alternatively, you can also use a download manager (to help avoid corrupt downloads) such as IDM and do a manual download from your Orbx Direct account web page (this is where a download manager works great) and click on the account button top of page, then find and click on the product info, and in the bottom line small print there is a manual download option, down load it and save it in a named folder, then open FTXC3 and select it, and click on the orange "installation options" and select "Install from my manually downloaded .zip". as per the below links. :)





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...