Jump to content

Why is it not possible to select the "using Simbrief .com" button instead of the"enter a Text Route" button?


Recommended Posts



You need to ensure your SimBrief username is in Settings > Connections. Please note it has to be your username and not the ID. Hope this helps :)

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...