Jump to content

Is it me? Problem in launching Orbx Central suddenly since MSFS recent update


Recommended Posts

Hi Folks, there must be a simple solution or something I may have done, but here goes... I installed Microsoft Flight Simulator in August and bought some products from Orbx which all installed perfectly well.

However, I noticed, after the last MSFS update (#5) over last weekend, that when I went to those airports I'd bought, they no longer appeared. Worse than that, I tried opening Orbx Central but to no response.

I have followed the various responses you have given to others including rebooting, deleting, doing this and that, but the best I get is the splash screen opens, then after I press install, it flashes and disappears. I have tried everything I know. Is there something simple I'm missing, please? (Yes, I did turn off anti-virus, firewall etc to install it). Thanks



Link to comment
Share on other sites

Hi Folks, I have managed to resolve this issue although it is strange. Holding down SHIFT key the image of the program appears, but then I had to go to the 'hidden' apps tab (didn't know the program was hidden but there you go) and double clicked there, the log-in page appeared an boom! It showed up. Hope this may help others unless it is just me, of course!!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...