Jump to content

Java Script error occured in the main process


Recommended Posts



Yesterday I purchased GB Central for X plane 11. I leftit downloading using Orbx Central and when I returned the app was closed and I was looking at my desktop. I tried to open Central to verify that the files were installed, but I cannot open the app. I get the error message 'A javascript error occured in the main process' - 'Uncaught exception: SyntaxError: Unexpected token.

When I run X plane, the files are not working.

The files appear to have been downloaded into my library, but I have no way of knowing if they are complete. 


Andy Christian




Operating system:  Windows 10

Simulator:  X Plane 11


Issue:  Can open Orbx Central and my recent purchase isn't working



Link to comment
Share on other sites

Hi Andy,


It appears something has crashed Central and this has caused one or more configuration files to become corrupt. 


You will need to delete the Central configuration files. Note that this will reset your Central settings back to defaults so you may need to set your library path again.


Can you delete the following files?

  • %AppData%/Orbx/Central/central.json
  • %AppData%/Orbx/Central/central.log

Try to launch Central. If the issue persists, let us know and we can troubleshoot this further.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...