Jump to content

resolved Orbx On external Drive- Folder structure


Recommended Posts

Hi all

I recently moved my Orbx True Earth GB stuff (and others ) to its own drive  F:

when doing this I changed the folder structure so they were all at the same level in the structure to make it easy to create symbolic links 

Now Orbx Central cant see the library, and appears to think I dont have any products installed..

Im happy to move the structure back to what is required if I need to but need to know what Central is actually expecting to see

Hope that makes sense !
screenshots attached 
Thanks

Bill P

Screen Shot 2022-01-20 at 11.19.25.jpg

Screen Shot 2022-01-20 at 11.14.28.jpg

Link to comment
Share on other sites

Here is the pertinent section from the Orbx central user guide regarding 

 

Moving a library to another location:

Moving a library is painless with Central and can be achieved in a few steps only: 1. Go to Settings > Libraries. 2. Note the directory of the library you’d like to move. 3. Remove the library that you would like to move (remember: this doesn’t delete the actual files). 4. Close Central by right-clicking on the tray and selecting “quit”. 5. Move the directory to the new location in your operating system. This step may take a while depending on your disk speed. 6. Start Central again 7. Open Settings, and then the Libraries page 8. Press ‘Create New Library’ 9. Select the new library location, give it a name and then press ‘Save’. Central will automatically scan the library for installed products, and then configure your simulators appropriately. 

 

Here is the section on Creating a Library

Creating a library The first time you start Central, you will be prompted to create a library. If you would like to create more libraries, you can do this by going to Settings > Libraries and clicking “create a new library”. This will prompt you to choose a name and an install location for this library. There are a few requirements when choosing a library location: ● You cannot choose a location that is within a simulator’s root directory. ● You cannot place a library at the root of a volume (you’ll need to create a directory). This means a location like D:\ is invalid, but D:\Library is valid. ● You cannot choose a directory that already contains files. If you have created a library in a prior version of Central, you can select that library’s location again. Central will intelligently re-sync the products in the existing library to your simulators.

I think maybe you did not follow all the necessary steps top create a new library?

 

@Nick Cooper Hi Nick. Any further suggestions?

 

 

Link to comment
Share on other sites

Thanks Jon..I think the problem MAY be that I moved stuff around in the original library folders as shown above  to make it clearer for me when creating symbolic links for Xorganiser 

hence asking what it SHOULD look like if it was left alone.... 

Everything works great in X plane its just central that doesn't see the library correctly 

Bill P
 

Link to comment
Share on other sites

Just an update..I fixed this by

Installing a NEW library location from central (a folder called Orbx2)

Then reinstalling TE North from Central to see where it went...

It was Orbx2/xp11/TrueEarth Great Britain North/Custom Scenery/ then the relevant separate TE folders..

Quite surprising it went into so many sub folders. !

SO..I then copied all other Orbx stuff to a similar location...  then went for INSTALL again on all

It then verified the files in that new location and accepted them

Seems a very long winded fix, but at least its now working 

Hope that helps someone else

Thanks Jon for the help 

Bil P

Screen Shot 2022-01-21 at 12.07.44.jpg

Link to comment
Share on other sites

  • 2 weeks later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...