Jump to content

resolved True Earth Great Britain Central (xplane 11) download is persistantly corrupt on my Mac


Recommended Posts

I purchased and downloaded True Earth Great Britain Central for my Mac version of XP11 yesterday.  At the end of the download and "unpacking," I got a message that stated that numerous files had an issue and that they may be resolved when I install it to my XP11 application folder.  I proceeded with the installation of True Earth GB Central into my XP11 folder.  XP 11, when launched started to load scenery and then proceeded to CTD.  I then removed XP11 from my Mac, downloaded it and installed a fresh version.  It performed fine. Then I downloaded another copy of True Earth GB Central and got a similar "file issues" prompt.  I did not install it this time.  Instead I simply chose the delete (or uninstall) button.  Then I tried to launch XP11 and, again, at scenery load, I got consistent CTDs.  I now running my third copy of XP11 on my Mac hoping that True Earth folks can take a look at this issue and to create a remedy.  I have True Earth Southern California and it downloaded, installed and runs fine in Mac XP11.

MacBook Pro 16 inch 2019, 2.4 GHz 8-Core Intel Core i9 with 32 GB 2667 MHz DDR4 memory and AMD Radeon Pro 5500M w/8GB.  Current Mac OS and XP11 versions.

Link to comment
Share on other sites

What is the situation at present? Is TEGB Central installed but crashing? If so i would ask for a copy of your XP log file please as it may indicate the cause of the issue.

If TEGB Central is not installed yet then please confirm that you meet all the requirements for installing True Earth addons as outlined in this link paying special attention to the needs for free space on disks, the location of your Temp folder and if you are maki9ng Backups.

Please tell me the free space on the Drive that you download onto

Is the drive you download onto the same drive that you are installing TEGB Central onto?

Once I have enough details of your setup etc I will be able to assist.

 

Link to comment
Share on other sites

Jon, Thanks for your quick response.  After my post, I also tried to add back the TE Southern California (which had been working without a problem since I purchased it) back into my xp and it too now seems to prevent my xp from launching past a short, "Loading new scenery." CTD follows.  I will walk through your response and see what I can do at this end..  After each re download of xp and just prior to adding TE files, I get a prompt to update my Orbx libraries, which I proceed to do.  On the surface, this seems to be the problem for me--BUT-- I will look at your notes here.  Thanks, again.  Jon Curwen.

Link to comment
Share on other sites

Thank you, again.  I only use one drive on my Mac - Macintosh HD.  I will be downloading all of the TE files onto it tomorrow.   I may have committed "pilot error" as I deleted files in my previous XP and TE install tries, BUT, failed to empty the trash.  Per your advice, I am checking and creating free space on my Mac HD.  I have about 930 GB so far. I also have a clean and working copy of XP set up today. Soon I will attempt to download my TE files from Orbx Central while observing the caveats mentioned by you.  If I have an issue tomorrow, is this the sort of XP "log" that is helpful?  It appeared at the launch of XP and immediately before the CTD.

Be Advised.jpg

Link to comment
Share on other sites

Hi. The pic of the error message is exactly what I need.

When reinstalling the TE addons please do one at a time and do a test flight in the region you have just installed so we can test it. Don't load them all and then start testing.

Your free space is getting better, but having only one disk drive means you need to need to take care.

If you have the make Backups option enabled in Orbx Central (see pic) it will store all the downloads from Orbx onto that drive as well which is using up space. If you have decent internet speed I suggest you untick the Backups option. If you uninstall an Orbx addon in Orbx Central and then go to reinstall it, it will read from the Backup copy as it will also do if you run the Verify Files option. If the original download is corrupted somehow, the a corrupted copy of the download will be installed and the issue perpetuates.

I therefore recommend you delete the Backups prior to reinstalling the TE addons.

The location of Backups storage place in Mac will be different from the location in the pic as that is from Windows, but I expect you will know the Mac equivalent.

65459444_InkedBackupslocation_LI.thumb.jpg.1fdad7bee1ea791474943693a97da1b2.jpg

Link to comment
Share on other sites

Thank you for the helpful information.  We are part way there. I did as you suggested and I was able to download TE SoCal, install and fly it just fine.  Free space of Mac HD went from 930GB down to 702GB as a result.  I also cleared Orbx Central Back up and unchecked the Back up option.  

 

Next, I proceeded to download TEMGB and got a repeat of my TEMGB issue.  I have not tried to proceed further in Orbx Central or XP.   Pix attached and is where I stand currently to see if you have any more help for me.  Last few times, "Verify Files" did not help. Mac HD free space is currently at 590 GB.

orbx_prompt.jpg

Link to comment
Share on other sites

Thanks for the feedback.

To try and get the conversion to work we need to try the following:

1.Use Orbx Central to uninstall TEGB Central

2.Reboot PC

3. Open Orbx Central/settings/downloader and scroll down to Conversions and click on the down arrow and choose Moderate a shown in the attached pic.

4. Reinstall TEGB Central

Capture.thumb.JPG.5f25b25df120108f049704011d9245fb.JPG

 

If that fails then please attach your Orbx Central log file by using Orbx Central/settings/help ad use a text editor to attach a copy of your Orbx Central log file as shown in pic below. I may well need to pass this issue over to the Orbx Central Support team as it appears to be a probable installation issue

44704431_OCLogfile.thumb.JPG.985ac91917306df2198a183b762c4f42.JPG

Link to comment
Share on other sites

Thank you for your response and suggestions.

 

Did steps 1-4 at start of your response.  The reinstall, step 4, seemed to go unusually fast.  About 1/10 time.  At finish, in Orbx Central,  I saw both TE SoCal and TE GB Central with the green checks.  

 

In XP, the TE SoCal worked fine.  However, the TE GB Central did a CTD during, "Loading new scenery."  I proceeded to Orbx Central Settings>Help>Open Log and created a WP file (attached herewith) of the contents on the screen.  On the Mac, it opens in "Console" for me.  

 

I then repeated the XP "New Flight" process with the same results -- successful TE SoCal, but unsuccessful TE GB Central with CTD.

castaicmac_central_log_file.rtf

Link to comment
Share on other sites

Not certain that this is still applicable, or, how it affects my issue...from the Orbx Central 2018 User Guide (pg. 5) for TE GB Central... 

 

"MacOS and Linux users

At time of publishing, FTX Central is not compatible with MacOS and Linux systems.

Please make use of the CROSS-PLATFORM DOWNLOAD available in your OrbxDirect account. This zip file will have the instructions for you to manually install Orbx TE Great Britain Central into MacOS/Linux as well as a script to perform the required texture conversion."

Link to comment
Share on other sites

If I understand you correctly then Orbx Central is not TEGB Central so TEGB Central is compatible with Mac. I am assuming you installed the Mac copy of Orbx Central as you have successfully installed TE SoCal.

Clear Temp folder using Orbx Central/settings/downloader

2021754633_ClearTempfolder.thumb.JPG.4ec20e7b0410a045bd5ec0454b9c3bbb.JPG

 

 

Run Verify Files for TEGB

Reboot then try this:

Rename Custom Scenery folder to Custom Scenery.bak

Make new Custom Scenery folder

Drag and drop TEGB Central files into the new Custom Scenery folder plus Global Airports. Nothing else.

Start XP11 and exit.

Open scenery_packs and make sure it is layered like this:

SCENERY_PACK Custom Scenery/Global Airports/

SCENERY_PACK Custom Scenery/Orbx_A_GB_Central_TrueEarth_Custom/
SCENERY_PACK Custom Scenery/Orbx_B_GB_Central_TrueEarth_Overlay/
SCENERY_PACK Custom Scenery/Orbx_C_GB_Central_TrueEarth_Orthos/

If possible disable plugins.

Load a flight in TEGB Central and only use the default Cessna 172 for a test flight.

Report back

Link to comment
Share on other sites

Your assumptions are correct.  Thanks for the detailed suggestions.   I did them, I believe, as presented by you, except for PLUG-INS disabling.  Have looked for online info on how to do that.  I don't believe that I have added any, personally.  

 

 

Did as you suggested above, I believe.  Spent most of day on this including some download time.  Had some confusion about the <scenery_packs.ini> files and may have screwed them up some how.  I have enclosed screenshots herewith.

So, early on after creating <Custom Scenery.bak> I got confused as to which <scenery_packs.ini> went where.  Then I lost both TE areas - SoCal and Central GB.  I could run flights in standard XP graphics.  I then saw that I no longer had TE SoCal in Orbx Central.  I downloaded it with the settings that you had suggested earlier.  As I write, I have 448 GB free space on my Macintosh HD.

 

TE SoCal runs fine in XP.  TE Central GB get a CTD at "Loading new scenery."

 

Here are the files...  and, thank you.

custom_scenery.jpg

custom_scenery.jpg

10-20_central.log..rtf

Link to comment
Share on other sites

Thanks for the feedback.

Please also now attach the XP log file that was made when the sim had a CTD. 

I am unable to determine the cause of your issue with TEGB Central so i am going to have to pass this over to the Orbx Central team to see if there is anything in the Orbx central Log file that may hint at what the cause is. 

 

@Nick Cooper Please pass this over to Orbx Central support unless you can advise what the Central log is telling us as to whether the addon is correctly installed or why there is always a CTD with TEGB Central. Thanks

 

10-20_central.log..rtf

Link to comment
Share on other sites

Thanks. I see nothing in the Log file suggesting a crash as it would normally be mentioned as the last written entry of the log file.I see that when you did the test with anew Custom Scenery folder you also included TE SoCal in it. I wanted only TEGB Central.

Would you peas do that for me as  I need to see the logs etc when only TEGB Central is installed in a new Custom Scenery folder

Make sure the scenery_packs looks like I mentioned before, that is like this:

SCENERY_PACK Custom Scenery/Global Airports/

SCENERY_PACK Custom Scenery/Orbx_A_GB_Central_TrueEarth_Custom/
SCENERY_PACK Custom Scenery/Orbx_B_GB_Central_TrueEarth_Overlay/
SCENERY_PACK Custom Scenery/Orbx_C_GB_Central_TrueEarth_Orthos/

Link to comment
Share on other sites

OK.  Per above, I think I have read your notes more carefully with rested eyes.  Got a CTD after I worked on my issue today and launched a flight out of Kirkbride, UK, which I assume tried to use the TE Central UK scenery files.  Attached herewith are two pix and xp log from a few moments ago.

Friday-1.jpg

Friday-2.jpg

XP-Friday-Log.txt

Link to comment
Share on other sites

Trying some stuff today...

Cleared my PRAM.  Did safe boot start.

From fresh boot, I failed to launch xp with TE GB Central - my system report attached as <KBsystem.log>

From fresh boot, I successfully launched xp with TE SoCal - my system report attache as <VNsystem.log>

 

Perhaps my comparative sys logs can provide insight to your trained eye.

KBsystem.log VNsystem.log

Link to comment
Share on other sites

Thanks. I am unable to determine the cause of your issue and need to pass this query over to a more technically knowledgeable colleague as it appears it could be an installation problem.

I would have preferred the XP log files for your latest tests rather than System log files.

@Nick Cooper please assist as I have gone as far as I can. Maybe you can see something that will help resolve the issue the customer is having or pass it to the Orbx central support team.

Link to comment
Share on other sites

Again, thanks for your efforts here.  Saturday, I labeled (purple) and moved some scenery files back into Custom Scenery so that I could enjoy the TE SoCal.  Here is the state of things along wit an xp log as of this morning, Sunday.  Flight out of SoSal works fine.  Flight out of Kirkbride, UK is CTD,  Each attempt involved a fresh boot.  More than happy to move files here and there at further direction from Orbx support.

custom_scen.jpg

cust_scen.bak.jpg

sun_log.rtf

Link to comment
Share on other sites

My Sunday PM experience seemed unusual.  I left my Mac on for several hours before getting back to it.  Then I launched xp while selecting Kirkbride, UK and it opened fine.  I took off toward Workington and flew over it and saw scenery that was far more complex than the xp defaults.  Maybe it was TE GB Central, which I have never seen before due to my issue.  HOWEVER, my Honeycomb Alpha  yoke "views" (left side of yoke 4-8 way view control) as well as my "Pause simulation" white button, and perhaps others (I don't use many of the buttons on the yoke) did not function.  Pitch and roll worked fine.  I landed on a street successfully and quit xp.  Rebooted and tried to launch from Kirkbride and got my usual CTD.  Then I tried Van Nuys, California, and all was fine - full TE SoCal  AND my Honeycomb unit was fully functional, i.e., normal.  Attached herewith is my log.txt. No changes made to my scenery folders since last post.  Hope this helps...

SundayPM_Log.txt

Link to comment
Share on other sites

Hi.

From what you describe it would appear that TEGB Central is working if you were able to fly without a CTD in your first effort. You then got a CTD on your second effort after a reboot if I understand correctly.( talking only TEGB Central her as SoCal seems OK).

You also had yoke problem when TEGB Central was running OK but yoke worked fine on SoCal.

This is very complex and difficult to analyse from a remote location especially as we now have thrown your Yoke into the mix.

Thanks for the Log but it relates to your successful flight in SoCal. I really need one from a CTD in TEGB Central to see if it tells me anything.

@Nick Cooper I also request you looking at this as well please or pass to the techies at Orbx central to see if they can help.

Link to comment
Share on other sites

Here is a <log.txt> from a very rare successful launch of xp11 from Kirkbride, UK.  It happened this morning.  Incidentally, it occurred after a Bluetooth issue with my Apple trackpad.  My last last successful Kirkbride, UK launch, a few days ago, occurred after a Bluetooth issue with my Apple keyboard.

Log copy.txt

Link to comment
Share on other sites

xp flight from Kirkbride to Workington...  I was able to take a screenshot, finally, with Honeycomb yoke buttons working intermittently.  Pitch and roll and trim worked fine.  Here is another log, also, immediately after I interrupted  this flight over Workington.  I assume that the TE GB Central graphics are what I'm seeing here as they are far more complex than the default xp graphics.  No Bluetooth issues preceded this flight.  I hope this info helps.

workington.jpg

Log.txt

Link to comment
Share on other sites

As you have proved there is nothing untoward or wrong with the addon of TEGB Central but more likely a random issue with some part of your hardware,  but glad to hear all is POK,..... for the moment:)

Yes your pic is displaying the Orbx True Earth textures

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...