Jump to content

active KTIW causing CTD


Recommended Posts

Hello.

I have had an issue for a while with KSEA where the sim kept on crashing every time I was on approach, and also when i was trying to load a flight from it. It was suggested by a user on the MSFS forums, after I went through several support request with Asobo, that the issue maybe caused by EGTB. According to him, this issue is known to happen but I don't own that airport. I tried disabling everything on my addons, not payware, but I ended up with the same problem. Finally he suggested that KTIW could be the problem, so I did uninstall it and sure enough, the problem was solved. This issue, for me at least, seems to happen only when I try to load a flight on or around the Seattle area, or when I'm on a final approach to KSEA.

It seems there is something with this airport causing the CTD. It was the only one that made a difference after I tried everything else.

As of now the airport is uninstalled until the problem is fixed by you.

Thanks

Edited by perohijo
added info
Link to comment
Share on other sites

Just to clarify... you cannot fly from or near KSEA if KTIW is installed with a CTD?

Yu say you tried after having disabled addons but not payware ones.

What payware addons have you got? Do you for example have addons from Drzewiecki Design for around Seattle?

Link to comment
Share on other sites

There are several similar topics regarding CTD in that area.#:

In the Search facility on this MSFS Support page enter KTIW and from the frop down menu choose This Forum. You will see many similar topics about KTIW and CTD caused by clashes of other addons.

Capture.thumb.JPG.247ca0570b3444bd06361b5c421608ae.JPG

 

Link to comment
Share on other sites

Guys,

 

Just to clarify, as the image for the  first linked post seems to suggest the issue has been fixed.  It hasn't. 

 

Orbx Tacoma Narrows still conflicts with other sceneries, to such an extent that I've removed it from my system for the time being. 

 

However, as more payware DLCs get released it's becoming apparent that it's not the only DLC with conflict problems.  If you read that first linked post fully you will see more info about the same kind of problem with a product from another developer. I expect it's something as simple as a file name conflict...

Edited by Majickthyse
Link to comment
Share on other sites

Hello.

Every time I add a new scenery either freeware or payware, I test it on the simulator, specially with the freeware addons, since it can have many incompatibilities. With the payware, I go and check the airport as soon as is installed, but I cannot go through each airport to see if it causes issues elsewhere. With that said, I have all freeware addons, and some payware, installed on an internal SSD drive and they are linked to the sim via addon linker. Some payware addons can be installed that way, but many others, such as Orbx, FlightBeam and other, install directly on the community folder. I disabled all the freeware addons and uninstalled the KTIW airport from Orbx Central. After I did that, I was able to fly to and from KSEA with no problem, even though I have Seattle landmarks installed as well, which of course, eliminates that scenery as a suspect. Since this problem went away with all the other payware addons installed and active, there is no doubt that KTIW caused the problem. Of course, since I didn't know that this addon was the problem before, I requested support from Asobo and followed all their recommendations and ended up with the same results.
You are saying that the cause of this problem maybe caused by something else, the fact in my case is that the problem was gone after I uninstalled KTIW. In my opinion, there are some other sceneries casing problems on this sim, not only Orbx. I had some bad performance with some  small airports, such as CYQM from Aerosoft, while I have great performance on major airports. I know this sim still very new and it is a work in progress, but really I hate the idea of spending hours trying to figure out what can be causing a problem rather than actually fly. But such is the nature of the beast. 
 
 
Link to comment
Share on other sites

This response will not solve your issue but I am questioning whether you are using Addon Linker to it's potential. You say that addons like Orbx and Flightbeam are installed into the Community folder. They only go in that folder if you direct the installation to that folder.

I have made a folder and in that folder on the same drive as my MSFS installation called MSFS Addons. With that folder I made another folder called Scenery. In that folder I made 3 more folders. 1 for EU/UK, 1 for Asia NZ and Aust and 1 for USA.

Each of those folders appears as libraries when i get an Orbx addon to install. I can then choose which folder to install into. it does not have to go into the Community folder.

See my pic below which shows my library folders for both XP and MSFS allowing me to install wherever I choose.

By having Regional scenery folders in MSFS via Addon linker I can enable only the addons I want for  a particular flight. For example If I am having a flight in the US on the west coast i only need to enable those addons relevant to that flight. I don't need Orbx UK or Asia addons loading up as well.

So it is not necessary to be obliged to install Orbx addons into the Community folder. You have options:

InkedLibraries_LI.thumb.jpg.eaade8311716aa6bb7f584ef1cbf02d8.jpg

 

 

This what my Addon Linker files look like. I have made different folders for different classification addons like Utilities/Aircraft/Liveries & Scenery by world regions:

 

Capture.thumb.JPG.86b165cde6d6cfc0d246e45319ca1d5b.JPG

 

  • Like 1
Link to comment
Share on other sites

Have you also tried just having the Seattle Landmarks and KTIW in the Community folder. It would only require your renaming the existing Community folder to Community.X or.BAK and make a new Community folder. Drag and drop from the old Community folder those 2 addons into the new one.

Try a flight and see if it causes a CTD

Link to comment
Share on other sites

Hi Jon,

 

I had hoped to use the MSFS Content Manager as intended but I think I am liking your idea of controlling payware through MSFS Addons Linker more and more with all these issues starting to arise. 

 

Where (on the Steam version) does MSFS allow you to specify the location for DLC to be saved to?

Edited by Majickthyse
Link to comment
Share on other sites

I don't have the Steam version I am afraid so i cannot answer that. Maybe a Steam version owner can chip in and advise you.

What i di though (Microsoft Store Premium de luxe version) is install to the sim, and then I drag and drop into the MSFS Addons folder to the correct scenery folder by region or by definition as illustrated in my attached pics of my Addon Linker set up.

You can place the addons (after installing into the sim) anywhere you want as long as the path to the location is indicated in Addon Linker.

Link to comment
Share on other sites

Hi

 

Just to add, and sorry if it is not very helpful.

I do not use the addon linker, or any other freeware or payware addons.

The only items I have installed are from Orbx Central.

I have flown around this area now for days and can not produce a CTD.

Even while Orbx Central is installing TE products to other simulators in the background.

Link to comment
Share on other sites

3 hours ago, Jon Clarke said:

I don't have the Steam version I am afraid so i cannot answer that. Maybe a Steam version owner can chip in and advise you.

What i di though (Microsoft Store Premium de luxe version) is install to the sim, and then I drag and drop into the MSFS Addons folder to the correct scenery folder by region or by definition as illustrated in my attached pics of my Addon Linker set up.

You can place the addons (after installing into the sim) anywhere you want as long as the path to the location is indicated in Addon Linker.

Right.  I've done that and up to a point it works fine. 

 

But how do you know if a Marketplace item has an update?  All I can see to do is move everything back to \Packages\Official, let the Marketplace do it's thing, and then move everything back again to the directory Addons Linker is using. 

 

That would be easy if it was only DLC in the \Packages\Official folder, but it also contains all the Asobo and Microsoft airports, plus some other stuff that I don't recognise.

Link to comment
Share on other sites

2 hours ago, Doug Sawatzky said:

Hi

 

Just to add, and sorry if it is not very helpful.

I do not use the addon linker, or any other freeware or payware addons.

The only items I have installed are from Orbx Central.

I have flown around this area now for days and can not produce a CTD.

Even while Orbx Central is installing TE products to other simulators in the background.

If you are only using Orbx DLCs then it's unlikely you would get the CTD.  So far the conflicts have been with DLCs from other devs.

Link to comment
Share on other sites

6 hours ago, Majickthyse said:

Right.  I've done that and up to a point it works fine. 

 

But how do you know if a Marketplace item has an update?  All I can see to do is move everything back to \Packages\Official, let the Marketplace do it's thing, and then move everything back again to the directory Addons Linker is using. 

 

That would be easy if it was only DLC in the \Packages\Official folder, but it also contains all the Asobo and Microsoft airports, plus some other stuff that I don't recognise.

I cannot answer that confidently as I do not use the marketplace. That is a question for Microsoft/Asobo. ALL my addons I put into the Community folder. This is the norm if you  install via Orbx Central or download from addon sites. It appears that marketplace is the only outlet that installs into the Official folder. 

Content Manager would advise if there was an update to a Marketplace addon would it not ?

Link to comment
Share on other sites

3 hours ago, Jon Clarke said:

Content Manager would advise if there was an update to a Marketplace addon would it not ?

It will advise by comparing the version in the Official folder to the latest version it has.  That's why moving things out of the Official folder comes with some peril. 

 

Am I missing something here?  Do you exclusively use Orbx add-ons or are you saying that Orbx Central can be used to install add-ons from any source?  Orbx Central would be of little use to me if it only installs Orbx products.

 

 

Link to comment
Share on other sites

I really would like to know if there is a fix for my problem. I have tried everything else and there's is nothing else causing my CTD other than KTIW. Other people may be having good performance with it installed, but I do know there are other users with the same problem. In my case, after uninstalling everything, disabling everything, and having everything up to date as well, it all comes down to KTIW causing the problem. I spent two days testing all my freeware and payware addons, and nothing else caused the problem other than that airport. 

I hope this explanation is good enough. I have no other issues or crashes except that one, and with all the addons I have reinstalled, including external programs, such as Rex weather force, Spadnext, or even the driver for honeycomb, everything works fine with some performance exceptions at some airports. 

Link to comment
Share on other sites

1 hour ago, perohijo said:

I really would like to know if there is a fix for my problem. I have tried everything else and there's is nothing else causing my CTD other than KTIW. Other people may be having good performance with it installed, but I do know there are other users with the same problem. In my case, after uninstalling everything, disabling everything, and having everything up to date as well, it all comes down to KTIW causing the problem. I spent two days testing all my freeware and payware addons, and nothing else caused the problem other than that airport. 

I hope this explanation is good enough. I have no other issues or crashes except that one, and with all the addons I have reinstalled, including external programs, such as Rex weather force, Spadnext, or even the driver for honeycomb, everything works fine with some performance exceptions at some airports. 

This topic was hijacked so I apologise.

You have not told me if you tried the suggestion I mentioned in my response to  you on Thursday? Please try it as it will at least know if there is a clash/conflict going on with another addon. First off i would just put KTIW in the new Community folder. Try a flight. If Ok then add the Seattle landmarks and try a flight. 

It is hard to determine the cause of your problem as others get a good performance

 

Quote

Have you also tried just having the Seattle Landmarks and KTIW in the Community folder. It would only require your renaming the existing Community folder to Community.X or.BAK and make a new Community folder. Drag and drop from the old Community folder those 2 addons into the new one.

Try a flight and see if it causes a CTD

Unquote

 

 

Link to comment
Share on other sites

On 2/4/2021 at 2:21 AM, Jon Clarke said:

Have you also tried just having the Seattle Landmarks and KTIW in the Community folder. It would only require your renaming the existing Community folder to Community.X or.BAK and make a new Community folder. Drag and drop from the old Community folder those 2 addons into the new one.

Try a flight and see if it causes a CTD

Hello. I will try that, but as I explained on my last reply today, Seattle Landmarks is already installed and not causing any problems. I have the Landmarks installed on another folder for the US on a different SSD internal drive.

 

Edited by perohijo
update
Link to comment
Share on other sites

Ok.

Here are the results after I followed your suggestion.

I created another community folder and placed both, KTIW and Seattle Landmarks, fired the sim and loaded a flight from KTIW. While loading the flight the sim crashed. I removed KTIW and left only the landmarks and tried the same flight. The sim did not crashed, and I then loaded another flight from KSEA just with the Landmarks installed, and it loaded without a problem. This should be a clear indication of a problem with KTIW since there was nothing else on that community folder and the original was renamed. Also, all my freeware addons were disabled so there was nothing other than those two folders when I started the sim

Link to comment
Share on other sites

Thanks for your test and sharing your results.

As you know there are any many users of KTIW not having any crashes including myself so it is very hard to determine what the cause of the issue is in your case.

I will ask those with more knowledge than myself to see if they can assist.

Link to comment
Share on other sites

13 hours ago, Jon Clarke said:

Thanks for your test and sharing your results.

As you know there are any many users of KTIW not having any crashes including myself so it is very hard to determine what the cause of the issue is in your case.

I will ask those with more knowledge than myself to see if they can assist.

Thanks Jon. I really have no idea why KTIW is causing the CTD, for me anyway, but hey, this is MSFS we're talking here. I know you guys are trying to keep up with the sim and I also know the SDK still not done by any stretch, but I still believe this is the best sim and I hope you can find the issue.

Thanks

Link to comment
Share on other sites

At the moment its hard to judge any reasons for ctd because bing data has issues since 2 days, where everyone is suffering from ctd at payware airport (that seemingly have areal images).

 

Just saying, im not sure about the KTIW thing, it works fine for me. Just posting because maybe you tried it during the last 2 days and thought it gives ctd. But like mentioned, we all get them atm anywhere in the world.

 

https://forums.flightsimulator.com/t/bing-data-causing-crashes-with-add-on-airports-or-scenery/364649/11

Link to comment
Share on other sites

Nope, I've have had this problems for several weeks now. After all the testing with and without addons, the only one causing the CDT is KTIW. I did a few flights yesterday to  major airports with the A320 and other than minor stuttering, had no problems. I actually reinstalled the airport and sure enough it crashed the sim again. There is no point for me to reinstall this airport until the problem is solved. The irony here is, all my freeware addons are working flawlessly, so go figure. I know that there's still a lot going on with this sim, and I'm welling to wait, as long as they fix the problem and is not ignored for weeks. This why I'm so hesitant to buy new scenery but I guess time will tell.

Link to comment
Share on other sites

7 hours ago, perohijo said:

Nope, I've have had this problems for several weeks now. After all the testing with and without addons, the only one causing the CDT is KTIW. I did a few flights yesterday to  major airports with the A320 and other than minor stuttering, had no problems. I actually reinstalled the airport and sure enough it crashed the sim again. There is no point for me to reinstall this airport until the problem is solved. The irony here is, all my freeware addons are working flawlessly, so go figure. I know that there's still a lot going on with this sim, and I'm welling to wait, as long as they fix the problem and is not ignored for weeks. This why I'm so hesitant to buy new scenery but I guess time will tell.

If you are willing to do an experiment for me then install KTIW.

Open the folder when installed and then open the folder MaterialLibs.

You should see another folder inside there called mymaterials. Rename it to:

KTIWmaterials

Try a flight. KTIW doesn't contain a CGL file so you should not experience a CTD that is caused by the Bing Data issue, If you still get a CTD then it will be still the same issue your reporting.

This is only a test.

  • Like 1
Link to comment
Share on other sites

2 hours ago, Jon Clarke said:

If you are willing to do an experiment for me then install KTIW.

Open the folder when installed and then open the folder MaterialLibs.

You should see another folder inside there called mymaterials. Rename it to:

KTIWmaterials

Try a flight. KTIW doesn't contain a CGL file so you should not experience a CTD that is caused by the Bing Data issue, If you still get a CTD then it will be still the same issue your reporting.

This is only a test.

Ignore this for now please. I have omitted an important change required also to the Layout json file.

Link to comment
Share on other sites

I wanted to wait to see if the latest update to MSFS has had any effect on your situation. Although it was a World Update there was 24GB of other stuff downloaded including CGL updates and DEM etc.

Try an install now and let me know if you still get the problem. If you do then I will PM you with a test proposal.

Link to comment
Share on other sites

3 minutes ago, Jon Clarke said:

I wanted to wait to see if the latest update to MSFS has had any effect on your situation. Although it was a World Update there was 24GB of other stuff downloaded including CGL updates and DEM etc.

Try an install now and let me know if you still get the problem. If you do then I will PM you with a test proposal.


Wondering the same? Hoping the issue has been fixed with the latest update from Microsoft.

Link to comment
Share on other sites

Nope. It did not work, although I wasn't expecting it to work, considering the fact that after this update London Landmarks had compatibility problems, and London looked like it was just bombed! jeje

Anyway, I tried a flight from KTIW after reinstalling it and the sim crashed just like before.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...