Jump to content

Orbx does not find MSFS2020

Recommended Posts

I'm having the same issue.  When I open Orbx Central, it only shows me my P3d4.5 products and there is no place for me to select MSFS as another simulator.  How can I add MSFS to Orbx Central?  The app is up to date.  I have a significant number of products and I am hopeful that I can purchase some MSFS products through Orbx Central.  I checked settings, etc.  Also, my P3d4.5 is on my E drive and MSFS is on my SSD C Drive.  Could this be a problem for Orbx Central not seeing the new MSFS?

Link to comment
Share on other sites

I'm having the same issue (and I've run MSFS a lot since it came out!)  I've removed Orbx Central and re-installed it.


Probably relevant details - I bought my version through Steam and it's not installed on drive c:but on p:


The only FS that Central discovered was X Plane (also on p:) and I had to manually add FSX (Steam Edition) as that wasn't discovered.

Link to comment
Share on other sites

20 minutes ago, Peter Watson said:

Fixed now by:

  • Uninstalling Orbx Central (again)
  • Removing *all* Orbx directories in c:\users\<name>\appdata\local and c:\users\<name>\appdata\roaming
  • Rebooting
  • Installing Orbx Central

I'm now checking that it's worked by installing the free OG20 scenery


This worked for me too. I noticed that three copies of Orbx Central were running in memory when I went to remove those directories. It seems they weren't properly ending when I closed them. That may have lead to my issues. Anyway, thanks for OG20, Orbx (and specifically Mark and Kyle)!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...