Jump to content

resolved TerraFlora and 2O3 Angwin-Parrett Field Invalid Licnese


Recommended Posts

2 hours ago, BrianV said:

To the best of my knowledge 2O3 Angwin Parrett Field has not been transferred to Orbx (at least not yet). However, TerraFlora should work and it is suggested to upgrade to TerraFlora2.

 

Correct on both points!!

 

Greg

  • Like 1
Link to comment
Share on other sites

3 hours ago, BrianV said:

To the best of my knowledge 2O3 Angwin Parrett Field has not been transferred to Orbx (at least not yet). However, TerraFlora should work and it is suggested to upgrade to TerraFlora2.

 

1 hour ago, Greg Jones said:

 

Correct on both points!!

 

Greg

Dosen't work. I can't find it in Orbx Central. And I don't want to upgrade I was happy with TerraFlora v1.

 

WhCIDOG.png

 

And when I click on info there is the transaction ID, date and down there: No download is currently available for Global TerraFlora. There is no neeed to pay additonal 10 AUD dollars I was satisfied with v1.

Edited by Almedin
Link to comment
Share on other sites

6 hours ago, Greg Jones said:

Just to confirm, are you saying that the original TerraFlora v1 installer you purchased does not work? 

 

G

Yes dosen't not work I got license error "Invalid license" for both products. 

Thanks,

Almedin

Edited by Almedin
Link to comment
Share on other sites

20 hours ago, Almedin said:

So, no support? Can someone from developers fix my problem?

 

According Turbulent's Facebook page, they're having some issues with their activation server which will be why your not able to get the installer to work. I'd suggest you keep an eye on that page for further updates.

 

Cheers,

 

Grerg

Link to comment
Share on other sites

2 hours ago, Greg Jones said:

 

According Turbulent's Facebook page, they're having some issues with their activation server which will be why your not able to get the installer to work. I'd suggest you keep an eye on that page for further updates.

 

Cheers,

 

Grerg

 

There's been issues with activation for many months, I and a number of other customers started threads on their support forum months ago re: being unable to install due to always receving an invalid license message (with a valid license of course).

 

There was a few replies, basically saying they were aware of the issue (as many customers were reporting) but were unable to reproduce and then silence.

 

If I had to guess I'd say whoever built the systems moved on and those remaining did not know how to resolve issues as the systems slowly broke, or maybe the effort vs. $$ didn't addup.

 

Whatever the cause and given the announced departure of Turbulent and the website/forum disappearing, I'd say kiss your v1 TerraFlora and whatever else you have ex Turbulent goodbye.

 

Then take up the offer of an inexpensive v2 TerraFlora (if not too late) and lament the loss of anything else you had from Turbulent...

 

Cheers

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...