Jump to content

resolved PAVD - Valdez Black Floor Areas instead of Terminal buildings


Recommended Posts

ID / receipt number 5ea471ac3bcc4

ID / receipt number 5ea4a3742cd69


Hello Support,

After the purchase of PAVD and Southern Alaska yesterday, instead of terminal buildings only black floor areas are to see... I have all globals (incl Buildings HD) except openLC Africa installed. Verified all of them via Central 4 as well as the Libraries. But still no terminal buildings generated (see attachment)... Please, advise thanks. 

PAVD Black Floor Areas.jpg

Link to comment
Share on other sites

Hello again Nick,

Thanks for your quick reply. I already checked for that. I first tried to remedy by verifying the objectflow files, then uninstalling followed by install. No terminal buildings afterwards... Object flow refuses to be installed in my main P3Dv4.5 folder, is this intentionally? I let it install in my Orbx Library folder where only TrueEarth Netherlands resides of all my Orbx products. Furthermore when clicking on Open of User Guide only an error seems to be available. Is this normal? Please, advise. Thanks. Michel

Link to comment
Share on other sites

Nick, I can open all pdf files perfectly with Adobe Acrobat Pro... What do you mean by "Orbx Library"? I have Orbx Libraries under Global Range installed in my main P3Dv4.5 folder. I made a Main Library under Settings on an SSD drive different from the SSD where P3Dv4.5 is located. I called this library "Orbx Library". It is precisely here that ObjectFlow has installed refusing to be installed where also the sim is installed. That's what Central 4 tells me beside giving an error if I try to open the objectflow guide.  What could be wrong? thanks for letting me know.

Link to comment
Share on other sites

Hi Nick, I can open the user guide from the provided link. The ObjectFlow user guide however keeps being unavailable and to me it looks not like a pdf reader refusal (see attachment)... I did create an external Orbx library dedicated to objectflow on the same SSD where P3Dv4.5 is installed, but of course outside the sim folder. When relaunching P3D it asks me to allow object flow as addon which I confirmed. I was hopeful to finally see some terminal buildings. But to my regret still only black fundations show up. Please, advise. Thx, M.

Pdf Guide ERROR.jpg

Link to comment
Share on other sites

OK, feature of guide missing despite a user guide icon for object flow, got that. Which product do you want me to reinstall? PAVD, South Alaska or objectflow? Under Settings\Help I let Central resynchronize my Sim, but still no terminal buildings in sight. My scenery complexity in Prepar is slided to the extreme right - Extremely Dense (see attachment). looking forward to your reply, thanks. Michel.


Link to comment
Share on other sites

Hello Nick, I reinstalled object flow, NA South Alaska and PAVD in this order. No terminal buildings... I'm getting quite desperate at this point. So time consuming on a sunny sunday. Please, advise. It looks like I'm also missing stools to have people properly seated on the tarmac. Michel

PAVD_Missing Ojbects.jpg

Link to comment
Share on other sites

Hi Doug,


Thanks for your assistance. Unfortunately, not leading to any solution yet. Please, take into account the following:

1) I 'm only using Orbx Central and FTX Central is uninstalled

2) I checked for a second instance of objectflow in my Prepar 3D v4 Add-ons folder. There is none.

3) I let Orbx Central install objectflow in a dedicated library as follows:     Z:\Orbx Object Flow Library\p3dv4\Orbx ObjectFlow. There is no ObjectFlow 2...

4) After installation of objectflow Prepar3D asked me to allow objectflow as an add-in which I confirmed.

5) Then P3Dv4.5 loads perfectly. To my surprise in the P3D menu bar under Add-ons objectflow is missing....

6) Apart from this Orbx issue my P3D sim works fine with plenty of additional airplanes and sceneries. Loading times reasonable and overall good frame rate.

What could prevent objectflow from loading after permission is asked and agreed on? Also what about that objectflow 2 when Orbx Central installs a folder simply named ObjectFlow? This is confusing...

Please advise, thanks.2115582097_P3Dv4.5MenuBar.thumb.jpg.dac9c57cbe392e8320eafc9a82e99d41.jpg





Link to comment
Share on other sites


although I am not sure that this is entirely objectflow related after all, the add-ons list that you should be looking at is at Options\add-ons.

I am sure that you will see it listed there.

You can access the same menu from the scenario screen, by clicking on the add-ons tab at the bottom.

Link to comment
Share on other sites

Good Evening Nick,


You're right, under Options\Add-ons I could indeed localize Orbx ObjectFlow 2 refering to my directory *\Orbx ObjectFlow. So, it is confirmed installed. Why doesn't it work to generate the terminal buildings in PAVD? On te tarmac there's people walking around  proof of displaying dynamic content. Why not the buildings??? Maybe some interference with some other addon .xml? Please, advise. Thanks, M

Link to comment
Share on other sites

Hey sorry for stepping in a bit late in the game. I'm the developer of Valdez.

Nick was correct assuming it was an ObjectFlow issue as most my sceneries use ObjectFlow to place buildings. That was not the case for PAVD though.


The buildings are actually not missing. You can see the antennas from the airport tower popping up :)

The issue seems to be related to airport elevation.


- Does the airport look correct in other areas? No big holes inside the airside area? Can you taxi and use the runway without sinking?


- Is the Orbx insertion point in the scenery.cfg in the top (can be set in Orbx Central under Settings -> Insertion Point)?


- Are you running FSAerodata or an AI-addon such as Mytraffic etc? A lot of these addons add custom airport files which quite often causes issues with our sceneries, especially altitude related ones (like this one for instance)


- Or do you have other addons for the area?


- Are you running any addon mesh?




Link to comment
Share on other sites


for what it's worth, I went to PAVD on my own PC and found that although the buildings were there, the airport elevation was broken.

This was undoubtedly my own fault, I do much testing on behalf of customers and do not always remember to return things to the

status quo afterwards.:(

I applied the sledgehammer approach and uninstalled and reinstalled both SAK and the airport.

You should be able to fix your problem by doing the same.

  • Like 1
Link to comment
Share on other sites

Good Morning and thanks for the follow-ups,


To Nick:

As messaged earlier I applied that sledgehammer approach in overdrive (also reinstalled Global openLC North America) without any change. Thanks anyway.


To Marcus:

Thanks for stepping in. I'll try to answer your questions as relevant as possible to my knowledge and logic:


1) Apart from being on a plateau when zooming out far enough into the approach lights of RWY 06, the airport is OK and the runway perfectly usable (no invisible obstructions, no floating RWY parts, no holes, no sinking of aircraft).


2) In decreasing order of priorities my Orbx scenery is layed out as follows:


2. FTX _NA_SAK08, *SAK07, *SAK06 and *SAK05

3. All Orbx!VECTOR except AEC just below Base Scenery Africa

4. AEC just above Base Scenery\Default Scenery

Thanks to Nick, to my joy this layout resolved my previous issues with Ketchikan Airport


3) I'm not running FSAerodata nor Mytraffic. I did apply the recent navdata updates of Herve Sors as I'm used to in order to keep the sim synchronised with Navigraph AIRAC database.


4) Using ADE 175, I extracted all PAVD airport bgl's I could find resulting in (listed in decreasing priority order):

1. FTX_AA_PAVD showing faulty Magnetic variation of -25 (inversed coding of 25E) and faulty ARP elevation of 75 ft

2. FTX_NA_SAK05_SCENERY also showing faulty Magnetic variation of -25 (inversed coding of 25E) and faulty ARP elevation of 75 ft

3. APX09100.bgl (stock airport) showing the 2015 Magnetic variation of -19 (inversed coding of 19E) and nearly correct ARP elevation of 118 ft.

Presumably Herve Sors used the official FAA data for his latest updates of which the Mag Var is lagging with 5 years. The actual Mag VAR of Valdez Airport is now 17E (-17 when inversed coded in P3D for 17E = Ntrue - Nmag = +17 Variation in real navigation terms). A discrepancy of 2 degrees is no big deal in contrast with 8 degrees as this should affect the RWY ID's with 1 unit...


5) Further observations:

Despite  the Orbx faulty ARP elevations of 75 ft, using QNH barometric setting the altimeter of the aircraft indicates 130 ft which is fair enough to match with the official ARP elevation of 121 ft. However, I suspect surrounding area of the ARP suddenly sinking to 75 ft... Hence the plateau and part of the approach lights floating in the air like festive sky lanterns.


6) I'm using all of FS Global Ultimate DL meshes priority being lower than all Orbx except for Vector and AEC


7) See all attachments for further insight. Due to upload constraints, please also check my next message.


Thanks for helping me out asap. Michel399851624_ActualMagVARPAVD.jpg.635f4ef3bddd531ba45939db5753f0bd.jpg239643100_OfficialFAADataPAVD.thumb.jpg.af800f805ca736729ee8ff1f44876616.jpg949512081_APX09100.bglExtractionPAVDAirport.thumb.jpg.854b5149762b5b02b3ebc520ca3214f6.jpg1836103571_FTX_NA_SAK05_SCENERYExtractedPAVDAirportBGL.thumb.jpg.e4e796043e807095b331108daa458ed5.jpg1003228775_FTX_AA_PAVDAirportBGL.thumb.jpg.cef9eacc661151ec51f7068d14a8ebac.jpg



Link to comment
Share on other sites

7 minutes ago, mikel7 said:

I did apply the recent navdata updates of Herve Sors as I'm used to in order to keep the sim synchronised with Navigraph AIRAC database.



this is what I suspect to be at least a part of the problem.

It seems to be the only difference between our installations.

Are you still not seeing any airport buildings?

Link to comment
Share on other sites

Can you try just unchecking the FS Global mesh and see if that fixes it?

Might be that it is overriding our mesh. It doesnt matter for mesh if it's higher or lower in the hierarcy, the highest will load.

If thats the case, we will need to check how we can override theirs.


Link to comment
Share on other sites

Dear Marcus,


I tried this before. Again now making sure all FS Global mesh is unabled via SceneryConfigEditor. Still no terminal buildings and Valdez airport on a plateau (see attachment of floating RWY lights). The heighth of this plateau looks to me to be the difference between the stock airport elevation of 118 ft en the faulty 75 ft of Orbx PAVD = 44 ft = 13.5 m. Could you maybe fix this...?

Thanks, Michel




Link to comment
Share on other sites

My only guess is that you have a file that is overrunning our files. I can't see any other explanation than that.

Have you tried searching for PAVD in your P3D folder and other folders where you keep your sceneries and addons installed?


The airport altitude for our scenery is not set to charts as FTX SAK was slightly different and we decided to prioritze blending.

I've tried deactivating FTX SAK PAVD files now to see if there is any connection to those but the changes does not seem to reflect what you are getting.

I also tried installing Herve Sors both Navaids and their fixes, but as you said, it doesnt seem to affect the scenery.


However, and of course there is a slight chance I am wrong, but in 95% of all cases I've had where altitude issues like this has happened to any of my sceneries, it has been due to a duplicate file causing the issue, often with no direct logic on why it has been added in the first place (ie with AI-addons etc).


Link to comment
Share on other sites

I tried installing in P3Dv3 as I got that platform pretty much clean, just to see what would happen with different scenarios.

I get your experience if having PAVD installed but not FTX SAK. With FTX SAK installed it is corrected.

Maybe the problem is somehow connected to your FTX SAK installation after all.


First image without FTX SAK installed,


Second with FTX SAK installed


Link to comment
Share on other sites

Hi Marcus,


I precisely bought FTX SAK hoping to make PAVD shine as intended. As mentioned earlier I already tried with both reinstalling FTX SAK and PAVD. No cure, not for elevation issues nor the black floors where the terminals should be placed on. I will do an extensive *PAVD* search through all my scenery files an let you know if anything comes up apart from the 3 airport bgl's communicated and opened in ADE 175. Personnaly I suspect an add-on .xml file, but I'm not familiar with this kind of file and not sure where to look. Any suggestion? Thanks, M

Link to comment
Share on other sites

Hi Nick,

Looking at the dates those must be compiled bgl airport files via ADE 175 to match true elevation and variation and in an effort to solve the plateau issue. Forgot about them... I could kill them all. Anything to eliminate from the xml's? M


Link to comment
Share on other sites

Hello Nick,


After the suggested removal of the 4 PAVD_ADEP4_ADE_*.bgl files (the ones in the KILLED folder are inactive) Valdez Pioneer Field looks like per attached screenshots. I used ADE 175 for a reason... With those mods PAVD is at least flyable. Without, a total mess. A bright spot: the terminal buildings made their appearance. Please, advise or patch. Maybe Orbx Valdez behaves as intended in P3D3, definitely not in P3D4.5 on my system.1327801019_ValdezTreshold06.thumb.jpg.02ab879f2e107e5eb6d718f8dd40f059.jpg



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...