Jump to content

Orbx Central - Errors Upon Installation

Recommended Posts

Hello Ladies/Gents,




I have recently purchased 'EU England' for use within FSX: SE and have followed the instructions including 'Orbx Central'.


Upon multiple installations, removing data from %AppData%, Local, and removing the Library files I am still welcomed with the same errors and unable to use any facility of the program.


I have checked the system requirements, and the software I have is beyond up to date, so this is not the cause of the issue, and I have also tried uninstalling via Add/Remove Programs within Windows 10 and tried to reinstall from a fresh download, again to no avail.


I have attached my central.log file also.


Any assistance would be appreciated!


Kind Regards,




Link to comment
Share on other sites

Hi Smudger,


Yes I have gone through each link and they are either already installed under a later version or repaired, there is no update that I don't have, especially running Windows 10 and fully up to date from Microsoft.


Which leaves me clueless unfortunately...

Link to comment
Share on other sites



1. Ensure your .net framework is updated with versions 2,3 and 4, using the tool found at the link.  http://www.asoft.be/prod_netver.html

2. Ensure your UAC is turned off, and that you are running as administrator.

3. Check and\or disable your antivirus and be sure it is not being blocked.

4. Have a close look in your computers program list for any other antivirus programs that may have been installed without your knowledge.

5. Ensure your windows firewall is allowing the app.


Link to comment
Share on other sites

Hi Doug,


Thanks for the points


Unfortunately, after working through the above, no joy on this matter still..


Attached central.log as of a relaunch following the check through the points made...


Antivirus is Off, UAC is Off, Firewall has the program allowed, .NET frameworks are all updated.




Link to comment
Share on other sites

Thanks Nathan


Assuming you have ran the simulator up to the default flight first before trying to install Orbx products.


Please try this next,


Use the FSX Registry Utility found at this link   https://www.tweakfs.com/store/free_tools.php  and use the "Set Path" option and point it to your  FSXSE installation.




Then open Orbx Central, go to settings\help and run the sync simulator function.



Link to comment
Share on other sites

Guest Josh Koz

Hi @NathanMoffatt2,


Looking at your log file, there seems to be a few unusual issues with your installation. A few things to try:

  • Ensure Orbx Central is running as an administrator and seeing if the issue persists.
  • Completely uninstall Orbx Central and reinstall the application.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...