Jump to content

Central Worker failed to launch and communication error


Recommended Posts



Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  Windows 10 pro

Simulator:  FSX and Xplane 11


Issue:  Hello, I have a new PC I started the reinstall of the ORBX products, the install was going just fine, have Global, Vector Land class, regions and some airports then I got the error message regarding communication and central worker and have made no further progress, I'm new to this so on the advise of a member I started this new post. I have reviewed the manual and tried the suggestions there, I'm sorry but I did a copy and paste of log file previously it was the entire log, please delete it. I appreciate your help.



Link to comment
Share on other sites

hello Nick, thanks for the advice, I've tried the suggestions in the manual, problem remains, whats odd is that I was able to restore approximately 50 products before the problem started, I cant remember the last item I installed before the error. I've never had a problem with any of your products as they have been the best in the business, just at a road block now and  lost .

Link to comment
Share on other sites

I use malwarebytes and whats built into Windows 10, I've had them both disabled, it will not get past the 2 errors. This is a new build PC but it was working as I installed all of the base and regions and a few other addons before it stopped working, I appreciate your help, hopefully the team can get me running again, I see some new addons I'd like to get, thanks again.

Link to comment
Share on other sites



You've mentioned that you are using Windows 10 but the Orbx Central log says it is running under Windows 8. This is most often caused by Orbx Central running under compatibility mode.


Right-click on your Orbx Central shortcut and press Properties. Under the Compatibility tab make sure that 'Run this program in compatibility mode for:' is disabled.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...