Jump to content

Orbx Central will not install


Recommended Posts

This is my first post on any forum, so please bear with me.

Orbx Central V 4.0.33 will not install. I have all five prerequisite software installed. The green bar goes to about 25% and stops. I tried my FTX3 but, it only gets to "paused" on downloads. 

FSX, windows 7 sp1, i5 cpu, 16 gigabytes ram, and, GeForce GTX660 GPU.


Central.log is attached.


I hope you can help, thank you.



Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached






Link to comment
Share on other sites


it seems that something is preventing Orbx Central from updating.

Please try uninstalling it, using your control panel and then re-installing

from any of the links on the Orbx Direct pages.

Please ensure that the System Requirements are all in place first.


System Requirements


Windows 7 SP1+, Windows 8.1 and Windows 10 are supported. The following components need to be installed for Central to function correctly:



Additional Requirements for Windows 7 and 8

Link to comment
Share on other sites


thank you very much for responding to my post. I tried your suggestion and Orbx Central installed and works fine! It's hard to believe sometimes that such a simple solution would work, but I'll take it. I am happy that my first forum post worked so well. Thanks again for your help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...