Jump to content

Can't install libraries or GB North


Recommended Posts


I have a Mac 
I have over 250GB space.  
I have installed the latest Orbx central - this is the only bit that actually works
I have tried many times to install the Libraries through Orbx central.  It just hangs.  I have then tried the direct download - this works and I get a download of approx 520mb.  Orbx central will then not install this.  I get communication errors but then if I persist it looks like it is installing but nothing happens - e.g. my latest attempt over 24 hours created a library file of only 13.1 mb
I have managed to then download the direct download of GB north at 22gb but it won’t work either until the libraries are installed.  
I have never had an issue with any other installation, I have no firewall I have a fast internet connection.  I have space.  Nothing works and its very frustrating.
Happy to send screen shots of all the above.




Operating system:  





Link to comment
Share on other sites

  • 2 weeks later...
Guest Josh Koz

Hi @Alasdair,


Can you attach your central.log file so we can look further into this issue for you? You can find your central.log file by opening Settings -> Help in Orbx Central and clicking open under Open Log.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...