Jump to content

Central freezes at the converting files step


Recommended Posts




Your Central log file provides us important information, please attach it to your support requests. You can find it at the following locations, or by pressing Control + Shift + L.

  • Windows: %APPDATA%/Orbx/Central/central.log
  • macOS: ~/Library/Application Support/Orbx/Central/central.log
  • Linux: ~/.config/Orbx/Central/central.log

You can delete this box/quote once your log is attached




Operating system:  Windows 10

Simulator:  Xplane 11


Issue:   appears to download compressed file but won't install. 

Several months ago, I purchased the entire True Earth GB series. I couldn’t install with FTX Central, and although I followed some suggestions posted on the forum, nothing worked. Finally, it was suggested I download Central, which I did. I still can’t enjoy my scenery and am really frustrated and disappointed. Central was supposed to solve installation issues, well it hasn’t for me.

I added a 4TB hard drive to my system which I use only for Xplane (my D drive). I created a separate library folder on my C drive. I even tried a manual download and install, but Central still won’t install.

It appears to download and possibly open the compressed files, but then won’t convert them. I tried with all of the scenery packages, with the same result; none showed a successful install.

Log and screen shot attached. Please just tell me how I can enjoy my scenery, I have spent many hours trying to install it.

central log.zipcentral log.zip1861923520_Centralinstallscreenshot.png.b351ee0fc7a45057f73bf0391b5d5f4a.png


Link to comment
Share on other sites

Hi Nick. I believe so, yes. I have read the Central guide, and have a link to it saved in my favourites. I have created a library in my C drive to manage downloads; the Install button was visible and presented as per the guide; I have set my firewall to recognise Orbx; my purchases are showing in Central as semi-transparent; I have automatic updates turned on in settings. Have I missed a step? Thanks.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...