Jump to content

Global vector does not install from the Orbx Central


Recommended Posts



I recently downloaded the new orbx central installer. Everything was going fine. I installed the libraries, global base pack. when I go to install the global vector, I just get the loading wheel for about a minute, then the action cancels out and doesn''t do anything. any help would be nice. Running FSX: steam editon

Link to comment
Share on other sites

  • 2 weeks later...
Guest Josh Koz

Hi @Zhazen


Are you still encountering this issue with the latest version of Orbx Central? If so, can you attach your central.log file so we can investigate this issue for you.

Link to comment
Share on other sites

Hi guys,

I have the exact same issue as Zhazen, with the newest ORBX Central for Windows 7 I can't download any products. It just keeps stuck at the loading wheel. I also tried to manually install the file downloaded from your website with the exact same result. I have a screenshot and the log file attached. Thanks for your help!



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...