Jump to content

active Unhandled exception has occurred Airport Elevation Correction


jammen737
 Share

Recommended Posts

FTX Global Vector

Order #:  

  • Transaction ID: 583cfa1341168

 

I am getting an error when trying to run auto-configuration for Airport Elevation Corrections.  I have tried uninstalling and then reinstalling with no avail.  I see that others have had the same issues in other threads.  I have not yet read one with an answer.  Here are the error details:

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.IOException: Cannot create a file when that file already exists.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.__Error.WinIOError()
   at System.IO.File.Move(String sourceFileName, String destFileName)
   at FtxVector.Configurator.Ui.Forms.MainForm.Aec_AutoBtn_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
FtxVector.Configurator
    Assembly Version: 1.35.0.0
    Win32 Version: 1.35.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Microsoft%20Games/Microsoft%20Flight%20Simulator%20X/ORBX/FTX_VECTOR/FTX%20GLOBAL%20VECTOR%20Configuration%20Tool.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.5483 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8686 (QFE.050727-8600)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5491 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5495 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5488 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


 

Link to comment
Share on other sites

Hello and welcome to the forums.

Vector settings are changed by means of renaming files from .bgl to .inactive.

If both versions of the files are already present, the software will generate this

error.

The only effective option is to delete the FTX_VECTOR folder

and re-install the product.

Link to comment
Share on other sites

On 12/6/2016 at 5:51 PM, jammen737 said:

 I see that others have had the same issues in other threads.  I have not yet read one with an answer.

 

Hi jammen737

 

Did any of the above solve your issue? An acknowledgement one way or the other would be very helpful for the next person searching. :):)

 

Cheers

 

Doug

Edited by Doogles
Link to comment
Share on other sites

 

I am not the OP but I've had this same problem for quite a while now.

 

I deleted the Vector folders and re-installed, but still I get the same issue -- unhandled exception.

 

 

Edited by Ripcord
Link to comment
Share on other sites

Hi all

 

I have exactly the same problem, I've checked through the complete error report.

 

I have FTX Central 3, an updated Vector and the latest .net framework. I deleted the .inactive files and selected all the options in the config programme and applied. I get the same exception error so is there any other option I should try before the delete and re-install? How can I do that effectively with FTX Central 3 installed, is there an uninstall option?

 

Thanks in advance

Jay

Link to comment
Share on other sites

  • 2 weeks later...
34 minutes ago, Doogles said:

Are you using Norton AV? I would just try running a reinstall without uninstalling or deleting anything, but not sure if you can do that with FTXC3. Open FTXC3 and click on Vector, is there a blue uninstall button?

 

Hi Doogle, no Norton AV but there is an uninstall option in FTXC3. Hoping not to do that at the moment. Last resort I will...

Link to comment
Share on other sites

 

This is the answer.

In this case, it has nothing to do with Regions, FTX Central, the .net framework or anti-virus software.

If you re-install without first deleting the FTX_VECTOR folder you will not solve the problem,

you will compound it.

 

Quote

 

Hello and welcome to the forums.

Vector settings are changed by means of renaming files from .bgl to .inactive.

If both versions of the files are already present, the software will generate this

error.

The only effective option is to delete the FTX_VECTOR folder

and re-install the product.

 

 
 

 

Link to comment
Share on other sites

I'm having similar issue with automatic Configuration.  It runs until I get this error and then if I say continue it never finishes and doesn't add any airports to the disabled list?  I uninstalled vector, erased Vector folder and then reloaded Vector 1.45, but get the same issue.  I'm running net framework ver 4.6.01586

 

*****************************************************

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.
************** Exception Text **************
System.FormatException: Input string was not in a correct format.
   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
   at System.Number.ParseDecimal(String value, NumberStyles options, NumberFormatInfo numfmt)
   at System.Convert.ToDecimal(String value)
   at FtxVector.Configurator.Ui.Forms.MainForm.Aec_AutoBtn_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
FtxVector.Configurator
    Assembly Version: 1.35.0.0
    Win32 Version: 1.35.0.0
    CodeBase: file:///C:/FSX/ORBX/FTX_VECTOR/FTX%20GLOBAL%20VECTOR%20Configuration%20Tool.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8750 (QFE.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
For example:
<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 
I'm not sure how to set debugging?  Thanks for your help
Bill Ditz
Transaction ID: 58253c99b82f5
  • Product: FTX Global VECTOR
  •  
 
Edited by bill721
updated info
Link to comment
Share on other sites

I did all the steps and still have the same problem. 

 

The files went to inactive and then back depending on the switch.  The only inactive files I have are the default files in the FTZ_Vector_apt scenery folder after switching all the fields back on.  Also there is a data file in the temp folder.

 

Do I need to delete the inactive default files?  Do I need to delete the temp folder?

 

Anything else we can try?

 

Bill

 

 

Edited by bill721
Link to comment
Share on other sites

 

Hi Nick, I hope you are well and have had a good Xmas.

 

I've completed an re-install through FTXC3 and I have some strange findings.

 

1. vector installed fine from a download through FTXC3 but the vector config utility hasn't been installed. The control panel button in the vector planel (FTXC3) is greyed out and the original Win 7 menu shortcuts haven't installed. It's possible that it's on my system but I'll need the file name to search for it.

 

2. I think the FTXC3 install placed the vector library entries in the wrong place. The set order is correct but they were inserted under the OLC entries which is counter to the graphic and advice in the manual.

 

Thanks in advance.

 

Jay

 

 

Link to comment
Share on other sites

2 hours ago, Nick Cooper said:

Hello,

The Vector tool file name is FTX GLOBAL VECTOR Configuration Tool.exe

The Vector scenery library entries should be just above 1107 Base.

 

Hi Nick

 

The vector library entries are in the right place now. Would I have had to load FSX and shut it down to see them correctly? I looked in the library straight after installation but I hadn't run FSX.

 

The config tool definitely hasn't installed from a fresh install of the latest vector on my PC. Might be worth checking that out. I have found a previous version of the tool from a back-up (Sept 2014), can I just copy and paste that into the correct place and run it or is it outdated or require other files to run correctly?

 

Thanks

Jay

Link to comment
Share on other sites

On 12/7/2016 at 6:42 PM, Doogles said:

 

Hi jammen737

 

Did any of the above solve your issue? An acknowledgement one way or the other would be very helpful for the next person searching. :):)

 

Cheers

 

Doug

I just deleted the Vector folder and re-installed.  Seems to be work at this time.  I don't see any .inactive files in the AEC folder this time.

  • Upvote 1
Link to comment
Share on other sites

On 25/12/2016 at 6:12 AM, bill721 said:

It still failed saying," input string was not in a correct format".  

 

I have uninstalled vector. Deleted the vector folder.  Reinstalled Vector. Removed all the files that shown .inactive.

 

Any other Ideas?

 

Bill

 

 

If you did this, you will have broken it.

 

The process is:

Delete the FTX_VECTOR folder.

Re-install Vector.

Done.

Link to comment
Share on other sites

Yes I'm still getting Unhandled exception has occurred in your application........  Input string was not in a correct format.

 

I've already uninstalled Vector, deleted vector folder and reinstalled from FTXC3.  I haven't tried uninstalling FTXC3.  Should I try that or something else?

 

Bill

 

 

Link to comment
Share on other sites

Nick, thanks for the installer.  Didn't fix the issue though.  Still getting same error.

I Deleted:

C:\Users\Your name\AppData\Local\Orbx and

C:\Users\Your name\AppData\Local\Temp\Orbx

 

Then ran the installer.  FTX Central v3.0.2.2 installed.

 

Rechecked Vector folders and all files are .bgl files.  OK

 

Ran migration trouble shooter and everything OK

 

Is there a way to find out which 'Input string was not in a correct format.'  causing the error?

 

I appreciate your help.

Bill 

 

Edited by bill721
updated info
Link to comment
Share on other sites

No problem.  We've had a few people on this thread.  I can't run the Vector Auto configuration utility.  Every time I attempt to run it I get a Microsoft .Net Framework error stating:

Unhandled exception has occurred in your application.  If you click Continue the application will ignore this error and attempt to continue...............  Then a line that says "Input string was not in a correct format" 

If press continue; the application never finishes.

I pasted the details of the error below.

I have reloaded Vector a couple of times.  I just reloaded FTX Central 3, and did Vector again and it still fails.

When I reload Vector I uninstall from FTX Central 3 and then Erase the Vector Folder prior to reloading.

 

I'm not sure which string is causing the issue so I can look further into it.  Is there a way to find that out?

 

Let me know if you have any other questions...

 

Bill

 

 

When I look at the Details tab it states:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.
************** Exception Text **************
System.FormatException: Input string was not in a correct format.
   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
   at System.Number.ParseDecimal(String value, NumberStyles options, NumberFormatInfo numfmt)
   at System.Convert.ToDecimal(String value)
   at FtxVector.Configurator.Ui.Forms.MainForm.Aec_AutoBtn_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
FtxVector.Configurator
    Assembly Version: 1.35.0.0
    Win32 Version: 1.35.0.0
    CodeBase: file:///C:/FSX/ORBX/FTX_VECTOR/FTX%20GLOBAL%20VECTOR%20Configuration%20Tool.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8750 (QFE.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8745 (WinRel.050727-8700)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
For example:
<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 
Link to comment
Share on other sites

Hi Guys,

I'm on my way to work now but will look at this one tonight.

 

In the meantime, it would help to those with issues to post what regional settings Windows is set to on your PCs.  

 

My current suspicion is that internally, one part of the code is using one number format (may have a comma in it) which is confusing another part of the program that is not set up to handle those formats.

 

Cheers,

Matt.

Link to comment
Share on other sites

Matt, If I understand you I'm set to United States and Central Time.  Let me know if you are asking something different and thank you for your assistance.

 

Bill Ditz

 

Edited by bill721
Link to comment
Share on other sites

Hi Matt, my region is U.K.

 

I'm not so sure about your potential fix as I cured my issue with a delete and reinstall of Vector. Obviously that's the limit of my knowledge but another common aspect could be FTXC3. I didn't have an issue with this until the unified lookup and FTXC3 install.

 

Trying to help, not criticise (to be clear).

 

all the best

Jay

Link to comment
Share on other sites

Thanks for the info guys. Keep 'em coming. It will help me reproduce this issue in a test environment.

My previous post was a guess based on experiences with that particular error. Looks like it may not be the case if it's happening with those region settings. I'll let you know what I find.

Cheers,
Matt.

Sent from my SM-N920I using Tapatalk


Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...